<!DOCTYPE html>
<html lang="en-US">
<head>
	<meta charset="UTF-8" />
	<link rel="pingback" href="https://tampa.cbslocal.com/xmlrpc.php" />

<!-- WP Header - Start -->
<meta name="news_keywords" content="covid-19, covid, testing, covid test, homosassa, florida, mobile testing, free, no-cost" />
<meta name="keywords" content="covid-19, cw44 news at 10, health, news, covid test, covid-19, florida, homosassa" />
<title>No-Cost Mobile Covid Testing In Homosassa November 8 &#8211; CBS Tampa</title>
<!-- Jetpack Site Verification Tags -->
<meta name="google-site-verification" content="44caXBf4kjHeKKAT7ZZ89NaCX25utL_yRSa-qGpwIhY" />
<link rel="dns-prefetch" href="//cdn.cookielaw.org" />
<script type="text/javascript" charset="UTF-8" src="https://cdn.cookielaw.org/scripttemplates/otSDKStub.js" data-domain-script="7547764e-53b9-4fff-aef7-ce9cb429c721"></script>
<link rel="dns-prefetch" href="//production-cmp.isgprivacy.cbsi.com" />
<script type="text/javascript" charset="UTF-8" src="https://production-cmp.isgprivacy.cbsi.com/dist/optanon-v1.1.0.js"></script>
<script type="text/javascript">!function(n){var o=window,a="cbsoptanon",c="cmd",d="config";o[a]=o[a]?o[a]:{},o[a][c]=o[a][c]?o[a][c]:[],o[a][d]=o[a][d]?o[a][d]:[],["onScriptsReady","onAdsReady"].forEach(function(n){o[a][n]=o[a][n]||function(){var d=arguments;o[a][c].push(function(){o[a][n].apply(o[a],d)})}})}();</script>
<link rel='dns-prefetch' href='//w3.cdn.anvato.net' />
<link rel='dns-prefetch' href='//maxcdn.bootstrapcdn.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel='dns-prefetch' href='//v0.wordpress.com' />
<link rel='dns-prefetch' href='//jetpack.wordpress.com' />
<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//s1.wp.com' />
<link rel='dns-prefetch' href='//s2.wp.com' />
<link rel='dns-prefetch' href='//public-api.wordpress.com' />
<link rel='dns-prefetch' href='//0.gravatar.com' />
<link rel='dns-prefetch' href='//1.gravatar.com' />
<link rel='dns-prefetch' href='//2.gravatar.com' />
<link rel="alternate" type="application/rss+xml" title="CBS Tampa &raquo; Feed" href="https://tampa.cbslocal.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="CBS Tampa &raquo; Comments Feed" href="https://tampa.cbslocal.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="CBS Tampa &raquo; No-Cost Mobile Covid Testing In Homosassa November 8 Comments Feed" href="https://tampa.cbslocal.com/2020/10/29/no-cost-mobile-covid-testing-in-homosassa-november-8/feed/" />
<link rel='stylesheet' id='all-css-0' href='https://tampa.cbslocal.com/_static/??-eJytj0sOwjAMRC9EsKpCBQvEWfIxJapjR/mI6xNSNqygEivbY7/RGB5RWeGCXKDcMWAGa7IisZrAs6XqXlLOcBMpmPat3cFPEAaDbmVjQhLtvsOR6uw5QxBXqW3026DV7XA/UEGznjF1mw9FtZBLkbjhpdWjBsPakyLPy/9TIbWJS//3Gi7D8TSM0+E8Tk91np9f' type='text/css' media='all' />
<link crossorigin="anonymous" rel='stylesheet' id='cbs-font-awesome-css'  href='https://maxcdn.bootstrapcdn.com/font-awesome/4.7.0/css/font-awesome.min.css?ver=4.7.0' media='all' />
<link crossorigin="anonymous" rel='stylesheet' id='cbs-lato-font-css'  href='https://fonts.googleapis.com/css?family=Lato%3A300%2C400%2C700%2C900&#038;ver=1.0.0' media='all' />
<link rel='stylesheet' id='all-css-4' href='https://tampa.cbslocal.com/_static/??-eJytU9FOwzAM/CGybGir4AHxLWlqdWFOHMXuqv49SemoxoC1iDc79p191kX3UVkKAkG0HMEDa1uzQrIGNcuAsLHMD/q3Nhcsdk15YtbRtKAEfEQjC7AFApgfg/D97ohd6wJrT02HuTI2KG9CHppGLhki7Feu3LtmXnnBFl/0pr9szkdKYunCMqcrxoOvofnAj6FCx6KsEYPUrpSRVTiLoM7z8a7qTabWdQae8pQ6mTRM7vAurFefL96CfF6/xDckvlMX2BtINHny82Z7QyEUVSTO0UK33veQN+lUqCeHElL6F29e89IZUp/cN5/kB+WFYsoL5NW/7Krt7vD0eKiqd6qcank=' type='text/css' media='all' />
<style id='wp-block-library-inline-css'>
.has-text-align-justify{text-align:justify;}
</style>
<script type='text/javascript' src='https://tampa.cbslocal.com/_static/??-eJydT8sSwiAM/CFp1PHRHhy/BYFWMARsQKd/L3Y82JOtp51ssrtZeEahAiVDCdLVeMOgLiwwKIlgSWHWhXIMMeDQWsTKW6ocr2Cu0M1SRMydJQYfdMaykXoUFxCP7bfDxPqeTT98YHHEeCC8JNmZ/m03IUTJuKUQF3VtM6lkA/FfnX88ZLBMlLj4nv1ps2/qpj7u1gf3An2Sp9Y='></script>
<script src='https://w3.cdn.anvato.net/player/prod/v3/scripts/anvload.js?ver=5.5.1' id='partner__video__anvato-js'></script>
<script type='text/javascript' src='https://tampa.cbslocal.com/_static/??-eJyFjcEOwjAMQ3+ILRsSTBwQ39KlUZcqbSeSst+nQrvswm6W/WzDtnZYslE2sIUSKeCsnRR0ApxRqm9WVHB+IeUP9YlzH/UC/4qND1JmJ6fk4eJtjEKnnVVq4KyQiq/Sko19IPtN7LJNvNJzvD3G4XqfpiF+AQq3VNA='></script>
<link rel="https://api.w.org/" href="https://tampa.cbslocal.com/wp-json/" /><link rel="alternate" type="application/json" href="https://tampa.cbslocal.com/wp-json/wp/v2/posts/231954" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://tampa.cbslocal.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://tampa.cbslocal.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 5.5.1" />
<link rel='shortlink' href='https://cbsloc.al/35JPm8t' />
<link rel="alternate" type="application/json+oembed" href="https://tampa.cbslocal.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Ftampa.cbslocal.com%2F2020%2F10%2F29%2Fno-cost-mobile-covid-testing-in-homosassa-november-8%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://tampa.cbslocal.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Ftampa.cbslocal.com%2F2020%2F10%2F29%2Fno-cost-mobile-covid-testing-in-homosassa-november-8%2F&#038;format=xml" />
<style type='text/css'>img#wpstats{display:none}</style>
<meta property="og:title" content="No-Cost Mobile Covid Testing In Homosassa November 8" /><meta property="og:image" content="https://tampa.cbslocal.com/wp-content/themes/cbs-local/images/share-logos/default.png" /><meta property="og:image:secure_url" content="https://tampa.cbslocal.com/wp-content/themes/cbs-local/images/share-logos/default.png" /><meta property="og:image:width" content="640" /><meta property="og:image:height" content="360" /><meta property="og:description" content="Florida residents interested in being tested for Covid will soon have an opportunity to do so at no-cost in Homosassa." /><meta property="og:type" content="article" /><meta property="og:url" content="https://tampa.cbslocal.com/2020/10/29/no-cost-mobile-covid-testing-in-homosassa-november-8/" /><meta property="article:published_time" content="2020-10-29T15:10:30+00:00" /><meta property="article:suggested-social-copy" content="Florida residents interested in being tested for Covid will soon have an opportunity to do so at no-cost in Homosassa." /><meta property="article:opinion" content="false" /><meta property="article:content_tier" content="free" /><meta property="og:category" content="COVID-19,CW44 News At 10,Health,News" /><meta property="article:publisher" content="https://www.facebook.com/CBSTampaBay" /><meta property="article:author" content="https://www.facebook.com/CBSTampaBay" />

<meta name="twitter:card" content="summary_large_image"/><meta name="twitter:image" content="https://tampa.cbslocal.com/wp-content/themes/cbs-local/images/share-logos/default.png"><meta name="twitter:title" content="No-Cost Mobile Covid Testing In Homosassa November 8"/><meta name="twitter:description" content="Florida residents interested in being tested for Covid will soon have an opportunity to do so at no-cost in Homosassa."/><meta name="twitter:site" content="/CBSTampaBay"/>
<link rel="canonical" href="https://tampa.cbslocal.com/2020/10/29/no-cost-mobile-covid-testing-in-homosassa-november-8/" />
				<style>
					.main-story-wrapper .basicsection { margin-bottom: 20px; }
					.main-story-wrapper .basicsection span strong { display: block; font-size: 18px; margin: 0 auto 15px; }
					.main-story-wrapper .basicsection img { float: none !important; margin: 0 auto 15px; }
					.main-story-wrapper .basicsection br { margin-bottom: 5px; }
				</style>
			<link rel="amphtml" href="https://tampa.cbslocal.com/2020/10/29/no-cost-mobile-covid-testing-in-homosassa-november-8/amp/">
<script type="application/ld+json">{"@context":"http:\/\/schema.org","@type":"NewsArticle","publisher":{"@context":"http:\/\/schema.org","@type":"NewsMediaOrganization","@id":"https:\/\/tampa.cbslocal.com","url":"https:\/\/tampa.cbslocal.com","name":"CBS Tampa","foundingDate":"1941-07-01T14:30:00+00:00","logo":{"@type":"ImageObject","url":"https:\/\/tampa.cbslocal.com\/wp-content\/uploads\/sites\/15909843\/2018\/07\/2_cbs_tampabay.png?w=257"}},"url":"https:\/\/tampa.cbslocal.com\/2020\/10\/29\/no-cost-mobile-covid-testing-in-homosassa-november-8\/","mainEntityOfPage":{"@type":"WebPage","@id":"https:\/\/tampa.cbslocal.com\/2020\/10\/29\/no-cost-mobile-covid-testing-in-homosassa-november-8\/"},"headline":"No-Cost Mobile Covid Testing In Homosassa November 8","description":"Florida residents interested in being tested for Covid will soon have an opportunity to do so at no-cost in Homosassa.","keywords":["COVID-19","CW44 News At 10","Health","News","Covid Test","Florida","Homosassa","news","No-Cost Mobile Covid Testing In Homosassa November 8"],"datePublished":"2020-10-29T15:10:30+00:00","dateModified":"2020-10-29T15:10:30+00:00","video":{"@context":"https:\/\/schema.org","@type":"VideoObject","name":"Vote-By-Mail Tips: How To Avoid Common Errors","description":"PASCO COUNTY, Fla. (CW44 News At 10) - With vote-by-mail setting historical records this election year, CW44 News At 10 spoke with Pasco's Supervisor of Elections to help voters identify common errors and avoid them.\u00a0\r\n\r\n\u201cWe sent out about almost 40% of our entire voter roll [who] requested vote-by-mail ballots,\u201d said\u00a0Brian Corley, Pasco County Supervisor of Elections.\u00a0\r\n\r\nWith vote-by-mail shattering records across the country this year, mostly due to the pandemic, voters are raising questions about how to vote without having their ballot returned due to any voter error.\u00a0And since some of these details are vital to your vote being counted, we've created a checklist.\u00a0\r\n\r\nAfteryou\u2019vefilled in your ballot, put your ballot in the secrecy envelope and the secrecy envelope in the postage-paid return envelope. Enclose only your ballot.\u00a0\r\n\r\nNow this step is important: seal it and sign your name on the back where indicated. The signature on file at the supervisor of elections office is the signature that will be used to verify the one on your certificate envelope.\u00a0\r\n\r\nPrint the date next to your signature and mail your ballot back to -or drop it off at- any county supervisor of elections office or ballot drop-off location.\u00a0\r\n\r\nIf you make a mistake, that\u2019s ok. Just call the supervisor of elections office to request another ballot. Their office will only accept one ballot per person.\u00a0\r\n\r\n\u201cI hear this a lot with vote by mail ballots: \u2018someone can vote twice if you get two ballots.\u2019 No you really can\u2019t. If you vote by mail and you send two back, there\u2019s safe-guards in place. It only allows the receipt of the first one that comes back in,\u201d said Corley.\u00a0\r\n\r\nKeep in mind, the later your return your mail ballot, the less time you have to fix any signature deficiencies. Any errors are determined by the canvassing board who checks the validity of the ballot.\u00a0\r\n\r\nBecause postal delivery service has changed, voters are advised to allow at least one week for their ballot to be returned by mail to the supervisor of elections office.\u00a0\r\n\r\nNote that if you received a mail ballot but changed your mind and want to vote at your precinct, remember to take your mail ballot with you to your polling place. Poll workers will cancel that mail ballot and you\u2019ll be allowed to vote a regular ballot there.\u00a0\r\n\r\nRemember, vote-by-mail ballots won\u2019t be accepted at polling places. You must drop them off at one of the Supervisor of Elections offices by 7 p.m. on election day. There is no limit to the number of ballots a person may return on behalf of other voters. And don\u2019t forget, you can track your ballot.\u00a0","thumbnailUrl":"https:\/\/xheimmxl4gfvfghng2jjos4qhb.gcdn.anvato.net\/anv-pvw\/5DE\/108\/5DE108061CE24FFA9E1228D2A9FF62ED_5.jpg?Expires=1698624000&KeyName=mcpkey1&Signature=DOTRyHT8g2JePS1ijuYA7NOy-eM","uploadDate":"2020-10-27","duration":"T2M42S","contentUrl":"https:\/\/tampa.cbslocal.com\/video\/4824271-vote-by-mail-tips-how-to-avoid-common-errors\/","embedUrl":"https:\/\/tampa.cbslocal.com\/video\/4824271-vote-by-mail-tips-how-to-avoid-common-errors\/"}}</script>
<script>cbs_lib.load_script("//launch.newsinc.com/js/embed.js");</script><script type="text/javascript">cbs_ads.partners.add("amazon", "3063");if(!window["apstag"]){window["apstag"]={init:function(){window["apstag"]._Q.push(["i",arguments]);},fetchBids:function(){window["apstag"]._Q.push(["f",arguments]);},setDisplayBids:function(){},_Q:[]};}</script>

<script type="text/javascript">cbs_ads.partners.add("sharethrough", true);</script>
<script>cbs_ads.init("4128","CBS.TAMPA","news",["nocostmobilecovidtestinginhomosassanovember8","post","article","covid19","cw44newsat10","health","news","covidtest","florida","homosassa","featuredvideo"],{"page_type":"article"});cbs_ads.refresh.set_timer("1");</script>

<link rel="dns-prefetch" href="//www.googletagmanager.com" />
<script type="text/plain" class="optanon-category-4" src="https://www.googletagmanager.com/gtag/js?id=UA-127524872-2" async></script>
<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=UA-127524872-2" height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
<script type="text/plain" class="optanon-category-4">window.dataLayer=window.dataLayer || [];function gtag(){dataLayer.push(arguments);}gtag("js",new Date());gtag("set",{"dimension1":"covid-19;cw44-news-at-10;health;news;","dimension2":"article"});gtag("config","UA-127524872-2");</script>

		<style type="text/css" id="wp-custom-css">
			.single-post sup {
	vertical-align: super;
	font-size: 10px;
}		</style>
		<!-- WP Header - End -->

	<meta name="description" content="Florida residents interested in being tested for Covid will soon have an opportunity to do so at no-cost in Homosassa." />
<script>//<![CDATA[
		window['_cmpWrapper'] = {
			loaded: function(callback) { cbsoptanon.cmd.push(function(cmp) { cmp.ot.getState(callback); }); },
			getConsentFlag: function(callback) {
				window._cmpWrapper.loaded(function(tar, per, fun, soc) {
					var consent = 0; var consentState = [ per, fun, tar, soc, false ];
					for (var i = 0; i < consentState.length; i++) { if (consentState[i]) { var mask = 1 << i; consent |= mask; } }
					callback(consent);
				});
			}
		}
		//]]></script>

</head>

<body class="post-template-default single single-post postid-231954 single-format-standard desktop-display-type  and-temp-wide"><div id="wrapper" class="body-wrapper">

<div id="reptile_skin_1" class="cbs-ad-unit ad_gpt cbs-ad-skin" data-ad_location="skin"><script>cbs_load_skin_by_tile(1);</script></div><header id="page-header" class=""><div class="wrapper">

				<a href="https://tampa.cbslocal.com" id="header-logo"><img src="https://tampa.cbslocal.com/wp-content/uploads/sites/15909843/2018/07/2_cbs_tampabay.png?w=257" alt="CBS Tampa" /></a>
	
	<nav id="navigation-main" data-item-count="7"><ul class="top"><li class="menu-top-item item-0 section-item"><div class="cbs-thumbnail-link wo-hover" ><div class="title-wrapper"><strong class="title">Menu</strong></div></div></li><li class="menu-top-item item-1 w-link"><a href="http://cwtampa.cbslocal.com/" title="CW44" class="cbs-thumbnail-link wo-hover" ><div class="title-wrapper"><strong class="title">CW44</strong></div></a></li><li class="menu-top-item item-2 w-link w-submenu"><a href="http://tampa.cbslocal.com/category/news/" title="News" class="cbs-thumbnail-link wo-hover" ><div class="title-wrapper"><strong class="title">News</strong></div></a><div class="submenu"><div class="wrapper">
<section class="items-grid column-count-2 block-type-wpmenu layout-compact aspect-ratio-16-9" id="" >
		<header class="column-header">
				<h4 class="title">View All News</h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="/category/news" title="Latest News" class="cbs-thumbnail-link item-0" ><div class="title-wrapper"><strong class="title">Latest News</strong></div></a><a href="https://tampa.cbslocal.com/business-news/" title="Business" class="cbs-thumbnail-link item-1" ><div class="title-wrapper"><strong class="title">Business</strong></div></a><a href="http://tampa.cbslocal.com/category/cw44-news/" title="CW44 News At 10" class="cbs-thumbnail-link item-2" ><div class="title-wrapper"><strong class="title">CW44 News At 10</strong></div></a><a href="https://tampa.cbslocal.com/entertainment-news/" title="Entertainment" class="cbs-thumbnail-link item-3" ><div class="title-wrapper"><strong class="title">Entertainment</strong></div></a><a href="https://tampa.cbslocal.com/cnet-tech-news/" title="CNET Tech News" class="cbs-thumbnail-link item-4" ><div class="title-wrapper"><strong class="title">CNET Tech News</strong></div></a><a href="http://tampa.cbslocal.com/category/travel/" title="Travel" class="cbs-thumbnail-link item-5" ><div class="title-wrapper"><strong class="title">Travel</strong></div></a><a href="http://tampa.cbslocal.com/category/health/" title="Health" class="cbs-thumbnail-link item-6" ><div class="title-wrapper"><strong class="title">Health</strong></div></a><a href="https://tampa.cbslocal.com/category/only-cbs/" title="Only CBS" class="cbs-thumbnail-link item-7" ><div class="title-wrapper"><strong class="title">Only CBS</strong></div></a>		</div>
	</section>

<section class="items-grid enable-type-icons column-count-2 block-type-grid layout-3_column aspect-ratio-16-9" id="" >
		<header class="column-header">
				<h4 class="title">Featured Articles</h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="https://tampa.cbslocal.com/2020/10/29/holiday-travel-covid-2020-thanksgiving-christmas-gatherings/" title="Doctor Explains Why You Should Avoid Thanksgiving, Christmas Gatherings: &#039;Not Worth The Risk&#039;" class="cbs-thumbnail-link item-1604007678 content-type-video" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://tampa.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://tampa.cbslocal.com/wp-content/uploads/sites/15909843/2020/10/GettyImages-1206034828.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Doctor Explains Why You Should Avoid Thanksgiving, Christmas Gatherings: &#039;Not Worth The Risk&#039;</strong><em class="description">Dr. Mallika Marshall warns against large family gatherings this year due to the risk of spreading COVID-19. </em></div></a><a href="https://tampa.cbslocal.com/2020/10/29/pinellas-county-sheriffs-deputies-soon-to-be-fitted-with-body-cameras-3/" title="Pinellas County Sheriff&#039;s Deputies Soon To Be Fitted With Body Cameras" class="cbs-thumbnail-link item-1604007039 content-type-video" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://tampa.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://tampa.cbslocal.com/wp-content/uploads/sites/15909843/2020/10/PCSO_BodyCams_Gualtieri.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Pinellas County Sheriff&#039;s Deputies Soon To Be Fitted With Body Cameras</strong><em class="description">Body cameras will soon be fitted on Pinellas County deputies.</em></div></a>		</div>
	</section>

<section class="items-grid enable-type-icons column-count-2 block-type-grid layout-3_column aspect-ratio-16-9" id="" >
		<header class="column-header">
				<h4 class="title">Galleries</h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="https://tampa.cbslocal.com/photo-galleries/2020/01/26/62nd-annual-grammy-awards-red-carpet-gallery/" title="62nd Annual GRAMMY Awards Red Carpet Gallery" class="cbs-thumbnail-link item-1580080563 content-type-photo" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://tampa.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://tampa.cbslocal.com/wp-content/uploads/sites/15909843/2020/01/GettyImages-1202147976.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">62nd Annual GRAMMY Awards Red Carpet Gallery</strong><em class="description">The best looks from the 62nd annual GRAMMY Awards on CBS.</em></div></a><a href="https://tampa.cbslocal.com/photo-galleries/2019/07/01/apollo-11-the-eagle-has-landed/" title="Apollo 11: &#039;The Eagle Has Landed&#039;" class="cbs-thumbnail-link item-1561957201 content-type-photo" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://tampa.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://tampa.cbslocal.com/wp-content/uploads/sites/15909843/2019/06/apollofeat.png?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Apollo 11: &#039;The Eagle Has Landed&#039;</strong></div></a>		</div>
	</section>
</div></div></li><li class="menu-top-item item-3 w-link w-submenu"><a href="http://tampa.cbslocal.com/category/best-of" title="Best Of" class="cbs-thumbnail-link wo-hover" ><div class="title-wrapper"><strong class="title">Best Of</strong></div></a><div class="submenu"><div class="wrapper">
<section class="items-grid enable-type-icons column-count-6 block-type-grid layout-3_column aspect-ratio-16-9" id="" >
		<header class="column-header">
				<h4 class="title"><a href="http://tampa.cbslocal.com/category/best-of">Latest Headlines</a></h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="https://tampa.cbslocal.com/2020/05/22/quarantine-cooking-nonstick-cookware-guide/" title="Quarantine Cooking: Your Essential Nonstick Cookware Guide" class="cbs-thumbnail-link item-1590161120 content-type-video" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://tampa.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://tampa.cbslocal.com/wp-content/uploads/sites/15909843/2020/05/nonstickpans.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Quarantine Cooking: Your Essential Nonstick Cookware Guide</strong><em class="description">Step up your quarantine cooking with this guide to nonstick cookware.</em></div></a><a href="https://tampa.cbslocal.com/2020/05/22/how-to-6-easy-steps-to-make-homemade-soft-pretzels/" title="How To: 6 Easy Steps To Make Homemade Soft Pretzels" class="cbs-thumbnail-link item-1590161082 content-type-video" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://tampa.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://tampa.cbslocal.com/wp-content/uploads/sites/15909843/2020/05/homemadepretzel.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">How To: 6 Easy Steps To Make Homemade Soft Pretzels</strong><em class="description">Learn how to make your own homemade soft pretzels with these six easy steps!</em></div></a><a href="https://tampa.cbslocal.com/2020/05/15/recipes-vodka-in-vodka-sauce-why/" title="5 Vodka Sauce Recipes To Try This Week" class="cbs-thumbnail-link item-1589569648 content-type-video" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://tampa.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://tampa.cbslocal.com/wp-content/uploads/sites/15909843/2020/05/chowhound111.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">5 Vodka Sauce Recipes To Try This Week</strong><em class="description">And would you miss it if it wasn&#039;t there?</em></div></a><a href="https://tampa.cbslocal.com/2020/05/15/best-make-ahead-freezer-meals/" title="Try These Make-Ahead Freezer Meals Perfect For Weeknights" class="cbs-thumbnail-link item-1589569416 content-type-video" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://tampa.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://tampa.cbslocal.com/wp-content/uploads/sites/15909843/2020/05/freezerfood.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Try These Make-Ahead Freezer Meals Perfect For Weeknights</strong><em class="description">Set yourself up for easy weeknight dinners no matter what!</em></div></a><a href="https://tampa.cbslocal.com/2020/05/13/the-most-searched-recipe-in-every-state-during-quarantine-coronavirus/" title="Coronavirus Cooking: The Most Searched Recipe In Every State During Quarantine" class="cbs-thumbnail-link item-1589398031 content-type-video" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://tampa.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://tampa.cbslocal.com/wp-content/uploads/sites/15909843/2020/05/QuarantineRecipesFeat.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Coronavirus Cooking: The Most Searched Recipe In Every State During Quarantine</strong><em class="description">Find the most popular eats for your home state and across the country during the coronavirus quarantine.</em></div></a><a href="https://tampa.cbslocal.com/2020/05/13/how-to-make-homemade-bagels-quarantine/" title="Quarantine Recipes: How To Make Homemade Bagels" class="cbs-thumbnail-link item-1589397541 content-type-video" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://tampa.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://tampa.cbslocal.com/wp-content/uploads/sites/15909843/2020/05/bagelfeat.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Quarantine Recipes: How To Make Homemade Bagels</strong><em class="description">See how to make your own homemade bagels while stuck inside during quarantine.</em></div></a>		</div>
	</section>
</div></div></li><li class="menu-top-item item-4 w-link w-submenu"><a href="http://tampa.cbslocal.com/category/sports/" title="Sports" class="cbs-thumbnail-link wo-hover" ><div class="title-wrapper"><strong class="title">Sports</strong></div></a><div class="submenu"><div class="wrapper">
<section class="items-grid column-count-2 block-type-wpmenu layout-compact aspect-ratio-16-9" id="" >
		<header class="column-header">
				<h4 class="title">View All Sports</h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="https://tampa.cbslocal.com/category/sports/" title="Latest" class="cbs-thumbnail-link item-0" ><div class="title-wrapper"><strong class="title">Latest</strong></div></a><a href="http://tampa.cbslocal.com/category/sports/rays/" title="Rays" class="cbs-thumbnail-link item-1" ><div class="title-wrapper"><strong class="title">Rays</strong></div></a><a href="http://www.cbssports.com/nfl/teams/page/TB/tampa-bay-buccaneers" title="Bucs" class="cbs-thumbnail-link item-2" ><div class="title-wrapper"><strong class="title">Bucs</strong></div></a><a href="http://tampa.cbslocal.com/category/sports/lightning/" title="Lightning" class="cbs-thumbnail-link item-3" ><div class="title-wrapper"><strong class="title">Lightning</strong></div></a><a href="http://www.cbssports.com/nfl/" title="NFL" class="cbs-thumbnail-link item-4" ><div class="title-wrapper"><strong class="title">NFL</strong></div></a><a href="http://www.cbssports.com/mlb/" title="MLB" class="cbs-thumbnail-link item-5" ><div class="title-wrapper"><strong class="title">MLB</strong></div></a><a href="http://www.cbssports.com/nba/" title="NBA" class="cbs-thumbnail-link item-6" ><div class="title-wrapper"><strong class="title">NBA</strong></div></a><a href="http://www.cbssports.com/nhl/" title="NHL" class="cbs-thumbnail-link item-7" ><div class="title-wrapper"><strong class="title">NHL</strong></div></a><a href="http://www.cbssports.com/college-football/" title="NCAAFB" class="cbs-thumbnail-link item-8" ><div class="title-wrapper"><strong class="title">NCAAFB</strong></div></a><a href="http://www.cbssports.com/college-basketball/" title="NCAAB" class="cbs-thumbnail-link item-9" ><div class="title-wrapper"><strong class="title">NCAAB</strong></div></a>		</div>
	</section>

<section class="items-grid enable-type-icons column-count-2 block-type-grid layout-3_column aspect-ratio-16-9" id="" >
		<header class="column-header">
				<h4 class="title">Featured Articles</h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="https://tampa.cbslocal.com/2020/10/29/nfl-week-8-afc-east-picks-bills-patriots-jets-dolphins/" title="NFL Week 8 AFC East Picks: Bills &#039;Should Take Care Of Their Business At Home&#039; Against Patriots, Says CBS Boston&#039;s Levan Reid" class="cbs-thumbnail-link item-1603988324" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://tampa.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://tampa.cbslocal.com/wp-content/uploads/sites/15909843/2020/10/josh-allen-bills-1.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">NFL Week 8 AFC East Picks: Bills &#039;Should Take Care Of Their Business At Home&#039; Against Patriots, Says CBS Boston&#039;s Levan Reid</strong><em class="description">CBS Boston sports reporter breaks down AFC East matchups, with the Patriots as underdogs against the Bills, and the Dolphins beginning the Tua Tagovailoa era.</em></div></a><a href="https://tampa.cbslocal.com/2020/10/29/groin-injury-sidelines-atlanta-falcon-takk-mckinley-for-the-panthers-game/" title="Groin Injury Sidelines Atlanta Falcon Takk Mckinley For The Panthers’ Game" class="cbs-thumbnail-link item-1603976751" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://tampa.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://tampa.cbslocal.com/wp-content/uploads/sites/15909843/2020/10/Raheem-Morris.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Groin Injury Sidelines Atlanta Falcon Takk Mckinley For The Panthers’ Game</strong><em class="description">The Falcons head to Charlotte for a prime-time contest with the Panthers, and we now know that Takk McKinley has been ruled out for the game.</em></div></a>		</div>
	</section>

<section class="items-grid enable-type-icons column-count-2 block-type-grid layout-3_column aspect-ratio-16-9" id="" >
		<header class="column-header">
				<h4 class="title">Latest Galleries</h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="https://tampa.cbslocal.com/photo-galleries/2014/12/30/final-nfl-power-rankings/" title="Final NFL Power Rankings" class="cbs-thumbnail-link item-1419918619 content-type-photo" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://tampa.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://tampa.cbslocal.com/wp-content/uploads/sites/15909843/2014/12/460879088.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Final NFL Power Rankings</strong><em class="description">It&#039;s tough to keep up with all the action in NFL. Here&#039;s your final power rankings of the season.</em></div></a><a href="https://tampa.cbslocal.com/photo-galleries/2014/12/19/nfl-power-rankings-week-16/" title="NFL Power Rankings: Week 16" class="cbs-thumbnail-link item-1418966955 content-type-photo" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://tampa.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://tampa.cbslocal.com/wp-content/uploads/sites/15909843/2014/12/460465244.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">NFL Power Rankings: Week 16</strong><em class="description">It&#039;s tough to keep up with all the action in NFL. Here&#039;s your power rankings heading into Week 16.</em></div></a>		</div>
	</section>
</div></div></li><li class="menu-top-item item-5 w-link w-submenu"><a href="http://tampa.cbslocal.com/category/health/" title="Health" class="cbs-thumbnail-link wo-hover" ><div class="title-wrapper"><strong class="title">Health</strong></div></a><div class="submenu"><div class="wrapper"></div></div></li><li class="menu-top-item item-6 w-link w-submenu"><a href="http://tampa.cbslocal.com/category/contests/" title="Videos &amp; More" class="cbs-thumbnail-link wo-hover" ><div class="title-wrapper"><strong class="title">Videos &amp; More</strong></div></a><div class="submenu"><div class="wrapper">
<section class="items-grid column-count-1 block-type-wpmenu layout-compact aspect-ratio-16-9" id="" >
		<header class="column-header">
				<h4 class="title">Video</h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="https://tampa.cbslocal.com/live/cbsn-new-york/" title="CBSN NY" class="cbs-thumbnail-link item-0" ><div class="title-wrapper"><strong class="title">CBSN NY</strong></div></a><a href="https://tampa.cbslocal.com/live/cbsn/" title="CBSN" class="cbs-thumbnail-link item-1" ><div class="title-wrapper"><strong class="title">CBSN</strong></div></a><a href="https://tampa.cbslocal.com/live/cbs-sports-hq/" title="CBS Sports HQ" class="cbs-thumbnail-link item-2" ><div class="title-wrapper"><strong class="title">CBS Sports HQ</strong></div></a><a href="https://tampa.cbslocal.com/live/et-live/" title="ET Live" class="cbs-thumbnail-link item-3" ><div class="title-wrapper"><strong class="title">ET Live</strong></div></a>		</div>
	</section>
</div></div></li></ul></nav>
	
	
	<div id="info-search"><form action="https://tampa.cbslocal.com/search/" class="form"><input type="text" class="query" name="q" id="s" size="31" placeholder="Search..." /><input type="reset" class="reset" value="Reset" /><input type="submit" class="submit" value="&#xf002" /></form><span class="open-close" onclick="jQuery(document).ready(function(){jQuery('#info-search').toggleClass('open');});"></span></div>
</div></header>		<section class="page-ad-container page-pencil-ad-container-top">
			<div id="reptile_1_wrapper" class="ad-block-wrapper cbs-ad-unit-wrapper"><span id="ad_1"><div id="reptile_1" class="ad-block" data-ad_size="[[970,250],[970,66],[728,90]]" data-ad_location="top"><script>cbs_load_ad_by_tile("1");</script></div></span></div>		</section>
		
<div id="page-content" class="main-white page-block-container and-w-sidebar">
<header id="page-rubric" class="">

			<div class="banner-title-wrapper">
							<h1 class="title">No-Cost Mobile Covid Testing In Homosassa November 8</h1>
					</div>
	
	
	
	
	
</header>
<section class="page-columns"><section class="page-column three-column" id="article-entry-date-and-tags"><div class="column-header"><span class="post-subtitle">Homosassa Public Library, 4100 S. Grandmarch Ave., on Sunday, Nov. 8 from 9 a.m. to 4 p.m.</span><time class="post-date">October 29, 2020 at 3:10 pm</time><div class="column-header-metadata"><strong>Filed Under:</strong><span><a href="https://tampa.cbslocal.com/tag/covid-test/">Covid Test</a>, <a href="https://tampa.cbslocal.com/tag/covid-19/">COVID-19</a>, <a href="https://tampa.cbslocal.com/tag/florida/">Florida</a>, <a href="https://tampa.cbslocal.com/tag/homosassa/">Homosassa</a></div></div></section><section id="column_block_1" class="page-column and-content-column two-column"><div class="column-item story" id="main-story"><section class="column-item media-type-anvato  ratio-display" id="featured-media"><div id="floating-player-container" class="video-wrapper anvato"><div id="p0"></div><script>cbsoptanon.onScriptsReady(function(cmp){cmp.ot.targetingAllowed(function(a){if(a) AnvatoPlayer("p0").init({"mcp":"cbs","width":"100%","height":"100%","video":"4824271","autoplay":true,"titleVisible":false,"accessKey":"anvato_cbslocal_app_web_prod_547f3e49241ef0e5d30c79b2efbca5d92c698f67","accessControl":{"preview":false},"pInstance":"p0","plugins":{"dfp":{"clientSide":{"adTagUrl":"http:\/\/pubads.g.doubleclick.net\/gampad\/ads?sz=2x2&iu=\/4128\/CBS.TAMPA&ciu_szs&impl=s&gdfp_req=1&env=vp&output=xml_vast2&unviewed_position_start=1&url=[referrer_url]&description_url=[description_url]&correlator=[timestamp]","keyValues":{"categories":"[[CATEGORIES]]","program":"[[PROGRAM_NAME]]","siteSection":"featured"}}}},"shareLink":"https:\/\/cbsloc.al\/35JPm8t","video-type":"featured","expectPreroll":true,"expectPrerollTimeout":5});});});</script></div></section>
<div class="main-story-wrapper"><p>HOMOSASSA, Fla. (CW44 News At 10) &#8211; Florida residents interested in being tested for Covid will soon have an opportunity to do so at no-cost in Homosassa.</p>
<p>The State of Florida is opening a one-time mobile COVID-19 testing site at the Homosassa Public Library, 4100 S. Grandmarch Ave., on Sunday, Nov. 8 from 9 a.m. to 4 p.m.</p>
<p>The walk-up/drive-thru test site will be available at no cost on a first come, first serve basis for Florida residents with or without symptoms. ID required for adults. There is no age requirement.</p>
<p>It will be a nasopharyngeal (nasal) swab and individuals will be called or emailed within two days with results.</p>
<p><em><strong>TOP STORIES ON CBS TAMPA:</strong></em></p>
<p><em><strong>&bull;&nbsp;<a href="https://tampa.cbslocal.com/2020/10/29/pedestrian-struck-killed-by-car-wednesday-night-on-busch-boulevard-3/" target="_blank" rel="noopener noreferrer">Pedestrian Struck &amp; Killed By Car Wednesday Night On Busch Boulevard</a></strong></em></p>
<p><em><strong>&bull;&nbsp;<a href="https://tampa.cbslocal.com/2020/10/29/zeta-aftermath-570-thousand-georgians-without-power/" target="_blank" rel="noopener noreferrer">Zeta Aftermath: Over 570,000 Georgia Customers Without Power</a></strong></em></p>
<p><em><strong>&bull;&nbsp;<a href="https://tampa.cbslocal.com/2020/10/29/all-four-suspects-captured-in-clayton-state-university-shooting-3/" target="_blank" rel="noopener noreferrer">All Four Suspects Captured In Clayton State University Shooting</a></strong></em></p>
<div class="social-buttons">
	<div class="social-media-container vertical">
					<div class="social-share-items addthis_toolbox addthis_default_style addthis_32x32_style">
				<span><a class="addthis_button_facebook"  addthis:url="https://cbsloc.al/35JPm8t"></a><a class="addthis_button_twitter"  addthis:url="https://cbsloc.al/35JPm8t"></a><a href="#" class="addthis_button_linkedin"></a><a href="#" class="addthis_button_reddit"></a><a class="addthis_button_compact"  addthis:url="https://cbsloc.al/35JPm8t"></a></span>
			</div>
		
			</div>
</div></div></div><a href="#" id="enable-comments-button" class="generic-button-v1" onclick="document.getElementById('story-comments').style.display=(document.getElementById('story-comments').style.display==='block')?'none':'block';return false;">Comments</a>
	<style>
	#comments .comments-title,
	#comments #respond #reply-title {
		color: black;
		font-size: 16px;
		font-weight: normal;
		margin-bottom: 20px;
	}
	#comments a:hover {
		text-decoration: underline;
	}
	#comments .comment-list,
	#comments .comment-list .children {
		list-style: none;
		margin: 0;
	}
		#comments .comment-list .comment {
			border-top: 1px solid #eaeaea;
			padding: 20px 10px;
		}
			#comments .comment-list .comment .comment-body {
				color: black;
				font-size: 13px;
				position: relative;
			}
				#comments .comment-list .comment .comment-body p {
					margin: 5px 0 7px 0;
					overflow: hidden;
					padding: 0;
				}
			#comments .comment-list .comment .comment-author .avatar {
				float: left;
				height: 42px;
				margin-bottom: 10px;
				margin-right: 15px;
				width: 42px;
			}
			#comments .comment-list .comment .comment-author .fn {
				color: black;
				font-size: 13px;
				font-style: normal;
				font-weight: bold;
			}
			#comments .comment-list .comment .comment-author .says {
				display: none;
			}

			#comments .comment-list .comment .comment-meta {
				position: absolute;
				right: 0;
				top: 0;
			}
			#comments .comment-list .comment .reply {
				margin-left: 57px;
			}
			#comments .comment-list .comment .comment-meta a,
			#comments .comment-list .comment .reply a {
				color: #808080;
				font-size: 11px;
			}
				#comments .comment-list:hover .comment .comment-meta a,
				#comments .comment-list:hover .comment .reply a {
					color: #333;
				}
			#comments .comment-list .comment .reply .safe-comments-report-link:last-of-type {
				display: none;
			}
	#comments .comment-list .children {
		margin-left: 20px;
		margin-top: 20px;
	}
		#comments .comment-list .children .comment {
			border-top: none;
			padding-right: 0;
			padding-top: 0;
		}

	#comments #reply-title a {
		color: black;
		font-size: 13px;
		padding: 0 5px;
	}
		#comments #reply-title small a {
			font-weight: normal;
		}
	



</style>

<div class="commenting-container">
	<a name="comments" class="comments-location-beacon"></a>
	<section id="story-comments" class="column-item">

		<div id="comments" class="comments-area">

			
							<p class="must-log-in">You must <a href="https://tampa.cbslocal.com/wp-login.php?redirect_to=https%3A%2F%2Ftampa.cbslocal.com%2F2020%2F10%2F29%2Fno-cost-mobile-covid-testing-in-homosassa-november-8%2F%23respond">log in</a> to post a comment.</p>			
		</div>

	</section>
</div>
<div id="reptile_30_wrapper" class="ad-block-wrapper cbs-ad-unit-wrapper partner-container partner-sharethrough"><span id="ad_30"><div id="reptile_30" class="ad-block" data-ad_size="[[1,5]]" data-ad_location="partner-injected"><script>cbs_load_ad_by_tile("30");</script></div></span></div><div class="partner-container partner-taboola"><div id="taboola-block-2"></div></div></section><aside class="sidebar right-bar" rel="modular+"><div id="reptile_2_wrapper" class="ad-block-wrapper cbs-ad-unit-wrapper"><span id="ad_2"><div id="reptile_2" class="ad-block" data-ad_size="[[300,250],[300,600],[300,1050]]" data-ad_location="top"><script>cbs_load_ad_by_tile("2");</script></div></span></div><div id="" class="block sidebar-widget widget_cbs_follow_us_widget"><h3 class="title">Follow Us</h3>
		<div class="widget-content-wrapper">
			<a href="https://www.facebook.com/CBSTampaBay" target="_blank" title="facebook_url" class="cbs-thumbnail-link facebook_url" ><div class="title-wrapper"><strong class="title">facebook_url</strong></div></a><a href="https://twitter.com/CBSTampaBay" target="_blank" title="twitter_url" class="cbs-thumbnail-link twitter_url" ><div class="title-wrapper"><strong class="title">twitter_url</strong></div></a>		</div>

		</div><div id="" class="block sidebar-widget widget_top-posts"><h3 class="title"><span>Most </span> Viewed</h3><ul class='widgets-list-layout no-grav'>
					<li>
						<a href="https://tampa.cbslocal.com/2020/10/29/single-car-crash-in-st-pete-leaves-driver-and-passenger-dead-5/" title="Single Car Crash In St. Pete Leaves Driver and Passenger Dead" class="bump-view" data-bump-view="tp">
								<img width="55" height="55" src="https://i0.wp.com/tampa.cbslocal.com/wp-content/uploads/sites/15909843/2020/10/GettyImages-926719206.jpg?resize=55%2C55&#038;ssl=1" alt="Single Car Crash In St. Pete Leaves Driver and Passenger Dead" data-pin-nopin="true" class="widgets-list-layout-blavatar"/>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://tampa.cbslocal.com/2020/10/29/single-car-crash-in-st-pete-leaves-driver-and-passenger-dead-5/" title="Single Car Crash In St. Pete Leaves Driver and Passenger Dead" class="bump-view" data-bump-view="tp">Single Car Crash In St. Pete Leaves Driver and Passenger Dead</a>
							</div>
													</li>
										<li>
						<a href="https://tampa.cbslocal.com/2020/10/29/breaking-trump-to-hold-rally-at-bucs-stadium-near-early-voting-site-14/" title="President Trump To Host Rally At Bucs Stadium, Near Early-Voting Site" class="bump-view" data-bump-view="tp">
								<img width="55" height="55" src="https://i1.wp.com/tampa.cbslocal.com/wp-content/uploads/sites/15909843/2018/01/gettyimages-669855642.jpg?resize=55%2C55&#038;ssl=1" alt="President Trump To Host Rally At Bucs Stadium, Near Early-Voting Site" data-pin-nopin="true" class="widgets-list-layout-blavatar"/>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://tampa.cbslocal.com/2020/10/29/breaking-trump-to-hold-rally-at-bucs-stadium-near-early-voting-site-14/" title="President Trump To Host Rally At Bucs Stadium, Near Early-Voting Site" class="bump-view" data-bump-view="tp">President Trump To Host Rally At Bucs Stadium, Near Early-Voting Site</a>
							</div>
													</li>
										<li>
						<a href="https://tampa.cbslocal.com/2020/10/29/all-four-suspects-captured-in-clayton-state-university-shooting-3/" title="All Four Suspects Captured In Clayton State University Shooting" class="bump-view" data-bump-view="tp">
								<img width="55" height="55" src="https://i0.wp.com/tampa.cbslocal.com/wp-content/uploads/sites/15909843/2020/10/Web_ArrestGraphic_Template_GBI-CSU-apprehended.jpg?resize=55%2C55&#038;ssl=1" alt="All Four Suspects Captured In Clayton State University Shooting" data-pin-nopin="true" class="widgets-list-layout-blavatar"/>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://tampa.cbslocal.com/2020/10/29/all-four-suspects-captured-in-clayton-state-university-shooting-3/" title="All Four Suspects Captured In Clayton State University Shooting" class="bump-view" data-bump-view="tp">All Four Suspects Captured In Clayton State University Shooting</a>
							</div>
													</li>
										<li>
						<a href="https://tampa.cbslocal.com/2020/10/29/atlanta-police-department-shows-off-a-major-haul-of-confiscated-drugs-and-guns-4/" title="Atlanta Police Department Shows Off A Major Haul Of Confiscated Drugs And Guns" class="bump-view" data-bump-view="tp">
								<img width="55" height="55" src="https://i1.wp.com/tampa.cbslocal.com/wp-content/uploads/sites/15909843/2020/10/APD-Finds-Drugs-And-Guns.jpg?resize=55%2C55&#038;ssl=1" alt="Atlanta Police Department Shows Off A Major Haul Of Confiscated Drugs And Guns" data-pin-nopin="true" class="widgets-list-layout-blavatar"/>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://tampa.cbslocal.com/2020/10/29/atlanta-police-department-shows-off-a-major-haul-of-confiscated-drugs-and-guns-4/" title="Atlanta Police Department Shows Off A Major Haul Of Confiscated Drugs And Guns" class="bump-view" data-bump-view="tp">Atlanta Police Department Shows Off A Major Haul Of Confiscated Drugs And Guns</a>
							</div>
													</li>
										<li>
						<a href="https://tampa.cbslocal.com/2020/10/28/property-taxes-pay-by-nov-30-in-hillsborough-to-receive-4-discount-5/" title="Property Taxes: Pay By Nov. 30 In Hillsborough To Receive 4% Discount" class="bump-view" data-bump-view="tp">
								<img width="55" height="55" src="https://i0.wp.com/tampa.cbslocal.com/wp-content/uploads/sites/15909843/2020/10/Downtown-Tampa_Credit-Jon-Harsanje.jpg?resize=55%2C55&#038;ssl=1" alt="Property Taxes: Pay By Nov. 30 In Hillsborough To Receive 4% Discount" data-pin-nopin="true" class="widgets-list-layout-blavatar"/>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://tampa.cbslocal.com/2020/10/28/property-taxes-pay-by-nov-30-in-hillsborough-to-receive-4-discount-5/" title="Property Taxes: Pay By Nov. 30 In Hillsborough To Receive 4% Discount" class="bump-view" data-bump-view="tp">Property Taxes: Pay By Nov. 30 In Hillsborough To Receive 4% Discount</a>
							</div>
													</li>
										<li>
						<a href="https://tampa.cbslocal.com/2020/10/29/zeta-aftermath-georgia-customers-without-power-below-340000/" title="Zeta Aftermath: Georgia Customers Without Power Below 340,000" class="bump-view" data-bump-view="tp">
								<img width="55" height="55" src="https://i2.wp.com/tampa.cbslocal.com/wp-content/uploads/sites/15909843/2020/10/Tree-Down-Gwinnett.jpg?resize=55%2C55&#038;ssl=1" alt="Zeta Aftermath: Georgia Customers Without Power Below 340,000" data-pin-nopin="true" class="widgets-list-layout-blavatar"/>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://tampa.cbslocal.com/2020/10/29/zeta-aftermath-georgia-customers-without-power-below-340000/" title="Zeta Aftermath: Georgia Customers Without Power Below 340,000" class="bump-view" data-bump-view="tp">Zeta Aftermath: Georgia Customers Without Power Below 340,000</a>
							</div>
													</li>
										<li>
						<a href="https://tampa.cbslocal.com/2020/10/29/early-voting-sites-pinellas-has-5-sites-to-hillsboroughs-26-3/" title="Early Voting Sites: Pinellas Has 5 Sites To Hillsborough&#039;s 26" class="bump-view" data-bump-view="tp">
								<img width="55" height="55" src="https://i0.wp.com/tampa.cbslocal.com/wp-content/uploads/sites/15909843/2020/10/Voting-In-Pinellas-County.jpg?resize=55%2C55&#038;ssl=1" alt="Early Voting Sites: Pinellas Has 5 Sites To Hillsborough&#039;s 26" data-pin-nopin="true" class="widgets-list-layout-blavatar"/>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://tampa.cbslocal.com/2020/10/29/early-voting-sites-pinellas-has-5-sites-to-hillsboroughs-26-3/" title="Early Voting Sites: Pinellas Has 5 Sites To Hillsborough&#039;s 26" class="bump-view" data-bump-view="tp">Early Voting Sites: Pinellas Has 5 Sites To Hillsborough&#039;s 26</a>
							</div>
													</li>
										<li>
						<a href="https://tampa.cbslocal.com/2020/10/28/zeta-intensifies-packing-life-threatening-storm-surge-to-gulf-coast-4/" title="Zeta Intensifies, Packing Life-Threatening Storm Surge To Gulf Coast" class="bump-view" data-bump-view="tp">
								<img width="55" height="55" src="https://i2.wp.com/tampa.cbslocal.com/wp-content/uploads/sites/15909843/2020/10/hypatia-h_32ba8b22d2e50602b499da1f40913533-h_73b58aada70edd3711338cb13889371c.jpg?resize=55%2C55&#038;ssl=1" alt="Zeta Intensifies, Packing Life-Threatening Storm Surge To Gulf Coast" data-pin-nopin="true" class="widgets-list-layout-blavatar"/>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://tampa.cbslocal.com/2020/10/28/zeta-intensifies-packing-life-threatening-storm-surge-to-gulf-coast-4/" title="Zeta Intensifies, Packing Life-Threatening Storm Surge To Gulf Coast" class="bump-view" data-bump-view="tp">Zeta Intensifies, Packing Life-Threatening Storm Surge To Gulf Coast</a>
							</div>
													</li>
										<li>
						<a href="https://tampa.cbslocal.com/2020/10/27/police-shooting-gbi-investigating-teens-death/" title="Police Shooting: GBI Investigating Teen’s Death" class="bump-view" data-bump-view="tp">
								<img width="55" height="55" src="https://i2.wp.com/tampa.cbslocal.com/wp-content/uploads/sites/15909843/2020/10/GettyImages-943818644.jpg?resize=55%2C55&#038;ssl=1" alt="Police Shooting: GBI Investigating Teen’s Death" data-pin-nopin="true" class="widgets-list-layout-blavatar"/>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://tampa.cbslocal.com/2020/10/27/police-shooting-gbi-investigating-teens-death/" title="Police Shooting: GBI Investigating Teen’s Death" class="bump-view" data-bump-view="tp">Police Shooting: GBI Investigating Teen’s Death</a>
							</div>
													</li>
										<li>
						<a href="https://tampa.cbslocal.com/2020/10/14/patients-living-with-an-incurable-blood-cancer-have-a-new-option/" title="Patients Living With An Incurable Blood Cancer Have A New Option" class="bump-view" data-bump-view="tp">
								<img width="55" height="55" src="https://i2.wp.com/tampa.cbslocal.com/wp-content/uploads/sites/15909843/2020/09/Sponsoredpic1REAL.jpg?resize=55%2C55&#038;ssl=1" alt="Patients Living With An Incurable Blood Cancer Have A New Option" data-pin-nopin="true" class="widgets-list-layout-blavatar"/>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://tampa.cbslocal.com/2020/10/14/patients-living-with-an-incurable-blood-cancer-have-a-new-option/" title="Patients Living With An Incurable Blood Cancer Have A New Option" class="bump-view" data-bump-view="tp">Patients Living With An Incurable Blood Cancer Have A New Option</a>
							</div>
													</li>
					</ul>
</div><div id="reptile_31_wrapper" class="ad-block-wrapper cbs-ad-unit-wrapper big-right-ad sidebar-adhesive-ad"><span id="ad_31"><div id="reptile_31" class="ad-block" data-ad_size="[[300,250]]" data-ad_location="adhesion"><script>cbs_load_ad_by_tile("31");</script></div></span></div></aside></section>		<section class="page-ad-container page-pencil-ad-container-bottom">
			<div id="reptile_4_wrapper" class="ad-block-wrapper cbs-ad-unit-wrapper"><span id="ad_4"><div id="reptile_4" class="ad-block" data-ad_size="[[728,90]]" data-ad_location="bottom"><script>cbs_load_ad_by_tile("4");</script></div></span></div>		</section>
		

</div>


<footer id="page-footer" class="page-footer-type-menus-vertical">
			<section class="top"><div class="wrapper">
										<div id="component-social" class="footer-component social-follow-items type-blue size-24x24">
					<div class="social-align-wrapper">
						<span class="disclosure">Follow Us</span>
						<a href="https://www.facebook.com/CBSTampaBay" class="facebook" target="_blank">Facebook</a><a href="https://twitter.com/CBSTampaBay" class="twitter" target="_blank">Twitter</a>					</div>
				</div>
					</div></section>
	
			<section class="middle"><div class="wrapper">
			
<section class="items-grid block-menu layout-compact aspect-ratio-16-9" id="block-0" >
		<header class="column-header">
				<h4 class="title">Entertainment</h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="https://tampa.cbslocal.com/category/only-cbs/" title="Only CBS" class="cbs-thumbnail-link item-0" ><div class="title-wrapper"><strong class="title">Only CBS</strong></div></a><a href="/category/best-of/" title="Best Of" class="cbs-thumbnail-link item-1" ><div class="title-wrapper"><strong class="title">Best Of</strong></div></a><a href="https://tampa.cbslocal.com/category/travel/" title="Travel" class="cbs-thumbnail-link item-2" ><div class="title-wrapper"><strong class="title">Travel</strong></div></a><a href="http://cwtampa.cbslocal.com/" title="CW44" class="cbs-thumbnail-link item-3" ><div class="title-wrapper"><strong class="title">CW44</strong></div></a>		</div>
	</section>

<section class="items-grid block-menu layout-compact aspect-ratio-16-9" id="block-1" >
		<header class="column-header">
				<h4 class="title">Corporate</h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="http://tampa.cbslocal.com/about-us/" title="About Us" class="cbs-thumbnail-link item-0" ><div class="title-wrapper"><strong class="title">About Us</strong></div></a><a href="http://tampa.cbslocal.com/about-us/advertising-basics/" title="Advertise" class="cbs-thumbnail-link item-1" ><div class="title-wrapper"><strong class="title">Advertise</strong></div></a><a href="https://cwtampa.cbslocal.com/contactus/" title="Contact Us" class="cbs-thumbnail-link item-2" ><div class="title-wrapper"><strong class="title">Contact Us</strong></div></a>		</div>
	</section>
		</div></section>
	
			<section class="bottom"><div class="wrapper">
			<a href="https://tampa.cbslocal.com" class="logo"><img src="https://tampa.cbslocal.com/wp-content/themes/cbs-local/plugins/modules/theme-manager/images/cbs-local-logo-white.png" alt="CBS Tampa" /></a>
			<div class="copyright-wrapper">
				<span class="copyright">&copy;2020 CBS Broadcasting Inc. All Rights Reserved.</span>
									<span class="powered-by-wordpress">Powered by <a href="https://wpvip.com/?utm_source=vip_powered_wpcom&#038;utm_medium=web&#038;utm_campaign=VIP%20Footer%20Credit&#038;utm_term=tampa.cbslocal.com" rel="generator nofollow" class="powered-by-wpcom">WordPress.com VIP</a></span>
							</div>

			<div class="right-wrapper">
									<div class="terms-of-use">By viewing our video content, you are accepting the terms of our <a href="https://privacy.cbs/videoservices" target="_blank" title="Video Services Policy">Video Services Policy</a></div>
								<ul id="menu-final-footer-menu" class="nav-final-footer"><li id="menu-item-44045" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-44045"><a href="http://policies.cbslocal.com/privacy/current.html">Privacy Policy</a></li>
<li id="menu-item-44046" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-44046"><a href="http://policies.cbslocal.com/terms-of-use">Terms of Use</a></li>
<li id="menu-item-172019" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-172019"><a href="https://publicfiles.fcc.gov/tv-profile/wtog">Public File for WTOG-TV / CW 44</a></li>
<li id="menu-item-208371" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-208371"><a href="https://tampa.cbslocal.com/wp-content/uploads/sites/15909843/2020/09/EEO-10-1-2019-to-9-30-2020.pdf">Public File Contact Us for WTOG-TV / CW 44</a></li>
<li id="menu-item-218783" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-218783"><a href="https://ca.privacy.cbs">California Privacy/Info We Collect</a></li>
<li id="menu-item-218784" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-218784"><a href="https://ca.privacy.cbs/donotsell">Do Not Sell My Information</a></li>
<li id="menu-item-161080" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-161080"><a href="http://policies.cbslocal.com/mobile-app-agreement/">Mobile User Agreement</a></li>
<li id="menu-item-77985" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-77985"><a href="http://policies.cbslocal.com/privacy/current.html#onlinead">Ad Choices</a></li>
</ul>			</div>

						</div></section>
</footer>

<!--PARTNER SCRIPTS START-->
<div id="reptile_32_wrapper" class="ad-block-wrapper cbs-ad-unit-wrapper pixel-ad"><span id="ad_32"><div id="reptile_32" class="ad-block" data-ad_size="[[1,8]]" data-ad_location=""><script>cbs_load_ad_by_tile("32");</script></div></span></div><div id="reptile_33_wrapper" class="ad-block-wrapper cbs-ad-unit-wrapper pixel-ad"><span id="ad_33"><div id="reptile_33" class="ad-block" data-ad_size="[[1,6]]" data-ad_location=""><script>cbs_load_ad_by_tile("33");</script></div></span></div><div id="reptile_34_wrapper" class="ad-block-wrapper cbs-ad-unit-wrapper pixel-ad"><span id="ad_34"><div id="reptile_34" class="ad-block" data-ad_size="[[1,7]]" data-ad_location=""><script>cbs_load_ad_by_tile("34");</script></div></span></div>
<!--PARTNER SCRIPTS END-->


</div>

<link rel='stylesheet' id='all-css-0' href='https://tampa.cbslocal.com/wp-content/themes/cbs-local/plugins/modules/partners/css/partners.css?m=1563314876g' type='text/css' media='all' />
<script type='text/javascript' src='https://tampa.cbslocal.com/wp-includes/js/wp-embed.min.js?m=1598987407g'></script>
<script src='https://w3.cdn.anvato.net/player/prod/v3/scripts/anvload.js?ver=5.5.1' id='cbs-cbs-anvato-js'></script>

		<!--[if IE]>
		<script type="text/javascript">
			if ( 0 === window.location.hash.indexOf( '#comment-' ) ) {
				// window.location.reload() doesn't respect the Hash in IE
				window.location.hash = window.location.hash;
			}
		</script>
		<![endif]-->
		<script type="text/javascript">
			(function () {
				var comm_par_el = document.getElementById( 'comment_parent' ),
					comm_par = ( comm_par_el && comm_par_el.value ) ? comm_par_el.value : '',
					frame = document.getElementById( 'jetpack_remote_comment' ),
					tellFrameNewParent;

				tellFrameNewParent = function () {
					if ( comm_par ) {
						frame.src = "" + '&replytocom=' + parseInt( comm_par, 10 ).toString();
					} else {
						frame.src = "";
					}
				};

				
				if ( 'undefined' !== typeof addComment ) {
					addComment._Jetpack_moveForm = addComment.moveForm;

					addComment.moveForm = function ( commId, parentId, respondId, postId ) {
						var returnValue = addComment._Jetpack_moveForm( commId, parentId, respondId, postId ),
							cancelClick, cancel;

						if ( false === returnValue ) {
							cancel = document.getElementById( 'cancel-comment-reply-link' );
							cancelClick = cancel.onclick;
							cancel.onclick = function () {
								var cancelReturn = cancelClick.call( this );
								if ( false !== cancelReturn ) {
									return cancelReturn;
								}

								if ( ! comm_par ) {
									return cancelReturn;
								}

								comm_par = 0;

								tellFrameNewParent();

								return cancelReturn;
							};
						}

						if ( comm_par == parentId ) {
							return returnValue;
						}

						comm_par = parentId;

						tellFrameNewParent();

						return returnValue;
					};
				}

				
				// Do the post message bit after the dom has loaded.
				document.addEventListener( 'DOMContentLoaded', function () {
					var iframe_url = "https:\/\/jetpack.wordpress.com";
					if ( window.postMessage ) {
						if ( document.addEventListener ) {
							window.addEventListener( 'message', function ( event ) {
								var origin = event.origin.replace( /^http:\/\//i, 'https://' );
								if ( iframe_url.replace( /^http:\/\//i, 'https://' ) !== origin ) {
									return;
								}
								jQuery( frame ).height( event.data );
							});
						} else if ( document.attachEvent ) {
							window.attachEvent( 'message', function ( event ) {
								var origin = event.origin.replace( /^http:\/\//i, 'https://' );
								if ( iframe_url.replace( /^http:\/\//i, 'https://' ) !== origin ) {
									return;
								}
								jQuery( frame ).height( event.data );
							});
						}
					}
				})

			})();
		</script>

		<script type='text/javascript' src='https://stats.wp.com/e-202044.js' async='async' defer='defer'></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:9.0.2.1',blog:'162238304',post:'231954',tz:'-4',srv:'tampa.cbslocal.com'} ]);
	_stq.push([ 'clickTrackerInit', '162238304', '231954' ]);
</script>



<script type="text/javascript">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</script>

	
	
	
	
</body>
</html>