<!DOCTYPE html>
<html lang="en-US">
<head>
	<meta charset="UTF-8" /><script type="text/javascript">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</script>
	<link rel="pingback" href="https://tampa.cbslocal.com/xmlrpc.php" />

<!-- WP Header - Start -->
<meta name="news_keywords" content="roderick walker, arrest, beaten, sheriff victor hill, clayton county, sheriff&#039;s office, shean williams, attorney, devin barrington-ward," />
<meta name="keywords" content="georgia news, news arrest, attorney, beaten, clayton county, cw69 news at 10, devin barrington-ward, roderick walker, shean williams, sheriff victor hill, sheriff&#039;s office" />
<title>Protesters Blame Clayton Co. Sheriff For Policing Issues &#8211; CBS Tampa</title>
<!-- Jetpack Site Verification Tags -->
<meta name="google-site-verification" content="44caXBf4kjHeKKAT7ZZ89NaCX25utL_yRSa-qGpwIhY" />
<link rel="dns-prefetch" href="//cdn.cookielaw.org" />
<script type="text/javascript" charset="UTF-8" src="https://cdn.cookielaw.org/scripttemplates/otSDKStub.js" data-domain-script="7547764e-53b9-4fff-aef7-ce9cb429c721"></script>
<link rel="dns-prefetch" href="//production-cmp.isgprivacy.cbsi.com" />
<script type="text/javascript" charset="UTF-8" src="https://production-cmp.isgprivacy.cbsi.com/dist/optanon-v1.1.0.js"></script>
<script type="text/javascript">!function(n){var o=window,a="cbsoptanon",c="cmd",d="config";o[a]=o[a]?o[a]:{},o[a][c]=o[a][c]?o[a][c]:[],o[a][d]=o[a][d]?o[a][d]:[],["onScriptsReady","onAdsReady"].forEach(function(n){o[a][n]=o[a][n]||function(){var d=arguments;o[a][c].push(function(){o[a][n].apply(o[a],d)})}})}();</script>
<link rel='dns-prefetch' href='//w3.cdn.anvato.net' />
<link rel='dns-prefetch' href='//maxcdn.bootstrapcdn.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel='dns-prefetch' href='//v0.wordpress.com' />
<link rel='dns-prefetch' href='//jetpack.wordpress.com' />
<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//s1.wp.com' />
<link rel='dns-prefetch' href='//s2.wp.com' />
<link rel='dns-prefetch' href='//public-api.wordpress.com' />
<link rel='dns-prefetch' href='//0.gravatar.com' />
<link rel='dns-prefetch' href='//1.gravatar.com' />
<link rel='dns-prefetch' href='//2.gravatar.com' />
<link rel="alternate" type="application/rss+xml" title="CBS Tampa &raquo; Feed" href="https://tampa.cbslocal.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="CBS Tampa &raquo; Comments Feed" href="https://tampa.cbslocal.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="CBS Tampa &raquo; Protesters Blame Clayton Co. Sheriff For Policing Issues Comments Feed" href="https://tampa.cbslocal.com/2020/09/15/protesters-blame-clayton-co-sheriff-for-policing-issues/feed/" />
<link rel='stylesheet' id='all-css-0' href='https://tampa.cbslocal.com/_static/??-eJytj0kOwjAMRS9EsKoyLhBnyWBKVMeOMojrE1I2rKASK9vffl/f8IjKChfkAuWOATNYkxWJ1QSeLVX3knKGm0jBtG3tBn6CMBh0CxsTkmj3HY5UJ88ZgrhKbaPfBq2uh/uBCpr1hKnbfCiqhZyLxBUvLR41GNaeFHme/58KqU1c+r/XcBn2p2E87M7j8Ql1n59g' type='text/css' media='all' />
<link crossorigin="anonymous" rel='stylesheet' id='cbs-font-awesome-css'  href='https://maxcdn.bootstrapcdn.com/font-awesome/4.7.0/css/font-awesome.min.css?ver=4.7.0' media='all' />
<link crossorigin="anonymous" rel='stylesheet' id='cbs-lato-font-css'  href='https://fonts.googleapis.com/css?family=Lato%3A300%2C400%2C700%2C900&#038;ver=1.0.0' media='all' />
<link rel='stylesheet' id='all-css-4' href='https://tampa.cbslocal.com/_static/??-eJytU9FuwjAM/KFlGRMT4mHat6SpVUKdOIpdqv49SVeoGGi0094c23f2WRfdR2UpCATRcgAPrG3FCska1CwDwqtlftG/tblgsatLillH04AS8BGNLMAWCGBOBuHn3RG7xgXWnuoOc2VsUN6EPDSNXDJE2K5cuXf1vPKCLX7oTX/ZnA+UxNKFZX6uGA++gvobP4YKHYuyRgxSs1JGVuEsgjrNx7up15laVxnY5ilVMmmY3OFdWK8+X7wBuV6/xHckvlMX2BEkGtvewYWiisQ5WujU5/7xJrWFenInIaV/8eUtL50g9ck9+CAPVBf4FJf2L/+5+djvN9vd++7tDDMmaPY=' type='text/css' media='all' />
<style id='wp-block-library-inline-css'>
.has-text-align-justify{text-align:justify;}
</style>
<script type='text/javascript' src='https://tampa.cbslocal.com/_static/??-eJydT0ESwiAM/JA01tGxPTi+BYFWMARsQKe/Fzse7MnW00422d0sPKNQgZKhBOlqvGFQFxYYlESwpDDrQjmGGHDsLGLlLVWON7BU6BYpIubeEoMPOmPZSD2JC4jH7tthZn3PZhg/sDpiOhBekuzN8LabEaJk3FKIq7p2mVSygfivzj8eMlgmSlx8z/5UH9qmbY77be1efYin0Q=='></script>
<script src='https://w3.cdn.anvato.net/player/prod/v3/scripts/anvload.js?ver=5.5.1' id='partner__video__anvato-js'></script>
<script type='text/javascript' src='https://tampa.cbslocal.com/_static/??-eJyFjcEOwjAMQ3+ILQxpm3ZAfEuXRl2qtJ1Iyn6fCnHhwm6W/WzDsXdYslE2sI0SKeCqnRR0ApxRqm9WVHB+I+UX9YlzH/UC/4qND1JWJ6fkz8XTGIVOO7vUwFkhFV+lJQf7QPaZ+Mo28Uj3YVyG622apzG+AQq+VNQ='></script>
<link rel="https://api.w.org/" href="https://tampa.cbslocal.com/wp-json/" /><link rel="alternate" type="application/json" href="https://tampa.cbslocal.com/wp-json/wp/v2/posts/229900" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://tampa.cbslocal.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://tampa.cbslocal.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 5.5.1" />
<link rel='shortlink' href='https://cbsloc.al/3bXzxxN' />
<link rel="alternate" type="application/json+oembed" href="https://tampa.cbslocal.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Ftampa.cbslocal.com%2F2020%2F09%2F15%2Fprotesters-blame-clayton-co-sheriff-for-policing-issues%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://tampa.cbslocal.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Ftampa.cbslocal.com%2F2020%2F09%2F15%2Fprotesters-blame-clayton-co-sheriff-for-policing-issues%2F&#038;format=xml" />
<style type='text/css'>img#wpstats{display:none}</style>
<meta property="og:title" content="Protesters Blame Clayton Co. Sheriff For Policing Issues" /><meta property="og:image" content="https://tampa.cbslocal.com/wp-content/uploads/sites/15909843/2020/09/Protest-Web.jpg?w=1500" /><meta property="og:image:secure_url" content="https://tampa.cbslocal.com/wp-content/uploads/sites/15909843/2020/09/Protest-Web.jpg?w=1500" /><meta property="og:image:width" content="1500" /><meta property="og:image:height" content="1125" /><meta property="og:description" content="Protesters and an attorney representing Roderick Walker, a man arrested and beaten by deputies during a traffic stop on September 11, 2020, say his arrest is drawing attention to bigger issues with the Clayton County Sheriff." /><meta property="og:type" content="article" /><meta property="og:url" content="https://tampa.cbslocal.com/2020/09/15/protesters-blame-clayton-co-sheriff-for-policing-issues/" /><meta property="article:published_time" content="2020-09-15T06:39:26+00:00" /><meta property="article:suggested-social-copy" content="Protesters and an attorney representing Roderick Walker, a man arrested and beaten by deputies during a traffic stop on September 11, 2020, say his arrest is drawing attention to bigger issues with the Clayton County Sheriff." /><meta property="article:opinion" content="false" /><meta property="article:content_tier" content="free" /><meta property="og:category" content="Georgia News,News" /><meta property="article:publisher" content="https://www.facebook.com/CBSTampaBay" /><meta property="article:author" content="https://www.facebook.com/CBSTampaBay" />

<meta name="twitter:card" content="summary_large_image"/><meta name="twitter:image" content="https://tampa.cbslocal.com/wp-content/uploads/sites/15909843/2020/09/Protest-Web.jpg?w=1500"><meta name="twitter:title" content="Protesters Blame Clayton Co. Sheriff For Policing Issues"/><meta name="twitter:description" content="Protesters and an attorney representing Roderick Walker, a man arrested and beaten by deputies during a traffic stop on September 11, 2020, say his arrest is drawing attention to bigger issues with the Clayton County Sheriff."/><meta name="twitter:site" content="/CBSTampaBay"/>
<link rel="canonical" href="https://tampa.cbslocal.com/2020/09/15/protesters-blame-clayton-co-sheriff-for-policing-issues/" />
				<style>
					.main-story-wrapper .basicsection { margin-bottom: 20px; }
					.main-story-wrapper .basicsection span strong { display: block; font-size: 18px; margin: 0 auto 15px; }
					.main-story-wrapper .basicsection img { float: none !important; margin: 0 auto 15px; }
					.main-story-wrapper .basicsection br { margin-bottom: 5px; }
				</style>
			<link rel="amphtml" href="https://tampa.cbslocal.com/2020/09/15/protesters-blame-clayton-co-sheriff-for-policing-issues/amp/">
<script type="application/ld+json">{"@context":"http:\/\/schema.org","@type":"NewsArticle","publisher":{"@context":"http:\/\/schema.org","@type":"NewsMediaOrganization","@id":"https:\/\/tampa.cbslocal.com","url":"https:\/\/tampa.cbslocal.com","name":"CBS Tampa","foundingDate":"1941-07-01T14:30:00+00:00","logo":{"@type":"ImageObject","url":"https:\/\/tampa.cbslocal.com\/wp-content\/uploads\/sites\/15909843\/2018\/07\/2_cbs_tampabay.png?w=257"}},"url":"https:\/\/tampa.cbslocal.com\/2020\/09\/15\/protesters-blame-clayton-co-sheriff-for-policing-issues\/","mainEntityOfPage":{"@type":"WebPage","@id":"https:\/\/tampa.cbslocal.com\/2020\/09\/15\/protesters-blame-clayton-co-sheriff-for-policing-issues\/"},"headline":"Protesters Blame Clayton Co. Sheriff For Policing Issues","description":"Protesters and an attorney representing Roderick Walker, a man arrested and beaten by deputies during a traffic stop on September 11, 2020, say his arrest is drawing attention to bigger issues with the Clayton County Sheriff.","image":"https:\/\/tampa.cbslocal.com\/wp-content\/uploads\/sites\/15909843\/2020\/09\/Protest-Web.jpg?w=150&#038;h=150&#038;crop=1","keywords":["Georgia News","News","Arrest","attorney","beaten","Clayton County","CW69 News at 10","Devin Barrington-Ward","Roderick Walker","Shean Williams","Sheriff Victor Hill","Sheriff's Office","news","Protesters Blame Clayton Co. Sheriff For Policing Issues"],"datePublished":"2020-09-15T06:39:26+00:00","dateModified":"2020-09-15T06:39:26+00:00"}</script>
<script>cbs_lib.load_script("//launch.newsinc.com/js/embed.js");</script><script type="text/javascript">cbs_ads.partners.add("amazon", "3063");if(!window["apstag"]){window["apstag"]={init:function(){window["apstag"]._Q.push(["i",arguments]);},fetchBids:function(){window["apstag"]._Q.push(["f",arguments]);},setDisplayBids:function(){},_Q:[]};}</script>

<script type="text/javascript">cbs_ads.partners.add("sharethrough", true);</script>
<script>cbs_ads.init("4128","CBS.TAMPA","news",["protestersblameclaytoncosheriffforpolicingissues","post","article","georgianews","news","arrest","attorney","beaten","claytoncounty","cw69newsat10","devinbarringtonward","roderickwalker","sheanwilliams","sheriffvictorhill","sheriffsoffice","featuredvideo"],{"page_type":"article"});cbs_ads.refresh.set_timer("1");</script>

<link rel="dns-prefetch" href="//www.googletagmanager.com" />
<script type="text/plain" class="optanon-category-4" src="https://www.googletagmanager.com/gtag/js?id=UA-127524872-2" async></script>
<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=UA-127524872-2" height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
<script type="text/plain" class="optanon-category-4">window.dataLayer=window.dataLayer || [];function gtag(){dataLayer.push(arguments);}gtag("js",new Date());gtag("set",{"dimension1":"georgia-news;news;","dimension2":"article"});gtag("config","UA-127524872-2");</script>

		<style type="text/css" id="wp-custom-css">
			.single-post sup {
	vertical-align: super;
	font-size: 10px;
}		</style>
		<!-- WP Header - End -->

	<meta name="description" content="Protesters and an attorney representing Roderick Walker, a man arrested and beaten by deputies during a traffic stop on September 11, 2020, say his arrest is drawing attention to bigger issues with the Clayton County Sheriff." />
<script>//<![CDATA[
		window['_cmpWrapper'] = {
			loaded: function(callback) { cbsoptanon.cmd.push(function(cmp) { cmp.ot.getState(callback); }); },
			getConsentFlag: function(callback) {
				window._cmpWrapper.loaded(function(tar, per, fun, soc) {
					var consent = 0; var consentState = [ per, fun, tar, soc, false ];
					for (var i = 0; i < consentState.length; i++) { if (consentState[i]) { var mask = 1 << i; consent |= mask; } }
					callback(consent);
				});
			}
		}
		//]]></script>

</head>

<body class="post-template-default single single-post postid-229900 single-format-standard desktop-display-type  and-temp-wide"><div id="wrapper" class="body-wrapper">

<div id="reptile_skin_1" class="cbs-ad-unit ad_gpt cbs-ad-skin" data-ad_location="skin"><script>cbs_load_skin_by_tile(1);</script></div><header id="page-header" class=""><div class="wrapper">

				<a href="https://tampa.cbslocal.com" id="header-logo"><img src="https://tampa.cbslocal.com/wp-content/uploads/sites/15909843/2018/07/2_cbs_tampabay.png?w=257" alt="CBS Tampa" /></a>
	
	<nav id="navigation-main" data-item-count="7"><ul class="top"><li class="menu-top-item item-0 section-item"><div class="cbs-thumbnail-link wo-hover" ><div class="title-wrapper"><strong class="title">Menu</strong></div></div></li><li class="menu-top-item item-1 w-link"><a href="http://cwtampa.cbslocal.com/" title="CW44" class="cbs-thumbnail-link wo-hover" ><div class="title-wrapper"><strong class="title">CW44</strong></div></a></li><li class="menu-top-item item-2 w-link w-submenu"><a href="http://tampa.cbslocal.com/category/news/" title="News" class="cbs-thumbnail-link wo-hover" ><div class="title-wrapper"><strong class="title">News</strong></div></a><div class="submenu"><div class="wrapper">
<section class="items-grid column-count-2 block-type-wpmenu layout-compact aspect-ratio-16-9" id="" >
		<header class="column-header">
				<h4 class="title">View All News</h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="/category/news" title="Latest News" class="cbs-thumbnail-link item-0" ><div class="title-wrapper"><strong class="title">Latest News</strong></div></a><a href="https://tampa.cbslocal.com/business-news/" title="Business" class="cbs-thumbnail-link item-1" ><div class="title-wrapper"><strong class="title">Business</strong></div></a><a href="http://tampa.cbslocal.com/category/cw44-news/" title="CW44 News At 10" class="cbs-thumbnail-link item-2" ><div class="title-wrapper"><strong class="title">CW44 News At 10</strong></div></a><a href="https://tampa.cbslocal.com/entertainment-news/" title="Entertainment" class="cbs-thumbnail-link item-3" ><div class="title-wrapper"><strong class="title">Entertainment</strong></div></a><a href="https://tampa.cbslocal.com/cnet-tech-news/" title="CNET Tech News" class="cbs-thumbnail-link item-4" ><div class="title-wrapper"><strong class="title">CNET Tech News</strong></div></a><a href="http://tampa.cbslocal.com/category/travel/" title="Travel" class="cbs-thumbnail-link item-5" ><div class="title-wrapper"><strong class="title">Travel</strong></div></a><a href="http://tampa.cbslocal.com/category/health/" title="Health" class="cbs-thumbnail-link item-6" ><div class="title-wrapper"><strong class="title">Health</strong></div></a><a href="https://tampa.cbslocal.com/category/only-cbs/" title="Only CBS" class="cbs-thumbnail-link item-7" ><div class="title-wrapper"><strong class="title">Only CBS</strong></div></a>		</div>
	</section>

<section class="items-grid enable-type-icons column-count-2 block-type-grid layout-3_column aspect-ratio-16-9" id="" >
		<header class="column-header">
				<h4 class="title">Featured Articles</h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="https://tampaprofootballknockout.cbslocal.com/" title="Make Your Pick!" class="cbs-thumbnail-link item-1600179355 content-type-video" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://tampa.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://tampa.cbslocal.com/wp-content/uploads/sites/15909843/2020/09/knockout-make-your-pick-1024x576-2.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Make Your Pick!</strong><em class="description">Registration for the Knockout Pool has closed. Make sure to make your pick for this week! This is a national contest. </em></div></a><a href="https://tampa.cbslocal.com/2020/09/15/trump-unemployment-300-benefit-jobless-aid-lost-wages-assistance/" title="Trump&#039;s Additional $300 Unemployment Benefits Could Now Last Up To Six Weeks" class="cbs-thumbnail-link item-1600177877 content-type-video" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://tampa.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://tampa.cbslocal.com/wp-content/uploads/sites/15909843/2020/09/unemployment-line-1.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Trump&#039;s Additional $300 Unemployment Benefits Could Now Last Up To Six Weeks</strong><em class="description">Unemployed individuals who qualify for an additional $300 under Trump&#039;s Lost Wages Assistance program may receive up to six weeks worth of benefits.</em></div></a>		</div>
	</section>

<section class="items-grid enable-type-icons column-count-2 block-type-grid layout-3_column aspect-ratio-16-9" id="" >
		<header class="column-header">
				<h4 class="title">Galleries</h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="https://tampa.cbslocal.com/photo-galleries/2020/01/26/62nd-annual-grammy-awards-red-carpet-gallery/" title="62nd Annual GRAMMY Awards Red Carpet Gallery" class="cbs-thumbnail-link item-1580080563 content-type-photo" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://tampa.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://tampa.cbslocal.com/wp-content/uploads/sites/15909843/2020/01/GettyImages-1202147976.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">62nd Annual GRAMMY Awards Red Carpet Gallery</strong><em class="description">The best looks from the 62nd annual GRAMMY Awards on CBS.</em></div></a><a href="https://tampa.cbslocal.com/photo-galleries/2019/07/01/apollo-11-the-eagle-has-landed/" title="Apollo 11: &#039;The Eagle Has Landed&#039;" class="cbs-thumbnail-link item-1561957201 content-type-photo" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://tampa.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://tampa.cbslocal.com/wp-content/uploads/sites/15909843/2019/06/apollofeat.png?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Apollo 11: &#039;The Eagle Has Landed&#039;</strong></div></a>		</div>
	</section>
</div></div></li><li class="menu-top-item item-3 w-link w-submenu"><a href="http://tampa.cbslocal.com/category/best-of" title="Best Of" class="cbs-thumbnail-link wo-hover" ><div class="title-wrapper"><strong class="title">Best Of</strong></div></a><div class="submenu"><div class="wrapper">
<section class="items-grid enable-type-icons column-count-6 block-type-grid layout-3_column aspect-ratio-16-9" id="" >
		<header class="column-header">
				<h4 class="title"><a href="http://tampa.cbslocal.com/category/best-of">Latest Headlines</a></h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="https://tampa.cbslocal.com/2020/05/22/quarantine-cooking-nonstick-cookware-guide/" title="Quarantine Cooking: Your Essential Nonstick Cookware Guide" class="cbs-thumbnail-link item-1590161120 content-type-video" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://tampa.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://tampa.cbslocal.com/wp-content/uploads/sites/15909843/2020/05/nonstickpans.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Quarantine Cooking: Your Essential Nonstick Cookware Guide</strong><em class="description">Step up your quarantine cooking with this guide to nonstick cookware.</em></div></a><a href="https://tampa.cbslocal.com/2020/05/22/how-to-6-easy-steps-to-make-homemade-soft-pretzels/" title="How To: 6 Easy Steps To Make Homemade Soft Pretzels" class="cbs-thumbnail-link item-1590161082 content-type-video" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://tampa.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://tampa.cbslocal.com/wp-content/uploads/sites/15909843/2020/05/homemadepretzel.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">How To: 6 Easy Steps To Make Homemade Soft Pretzels</strong><em class="description">Learn how to make your own homemade soft pretzels with these six easy steps!</em></div></a><a href="https://tampa.cbslocal.com/2020/05/15/recipes-vodka-in-vodka-sauce-why/" title="5 Vodka Sauce Recipes To Try This Week" class="cbs-thumbnail-link item-1589569648 content-type-video" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://tampa.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://tampa.cbslocal.com/wp-content/uploads/sites/15909843/2020/05/chowhound111.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">5 Vodka Sauce Recipes To Try This Week</strong><em class="description">And would you miss it if it wasn&#039;t there?</em></div></a><a href="https://tampa.cbslocal.com/2020/05/15/best-make-ahead-freezer-meals/" title="Try These Make-Ahead Freezer Meals Perfect For Weeknights" class="cbs-thumbnail-link item-1589569416 content-type-video" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://tampa.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://tampa.cbslocal.com/wp-content/uploads/sites/15909843/2020/05/freezerfood.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Try These Make-Ahead Freezer Meals Perfect For Weeknights</strong><em class="description">Set yourself up for easy weeknight dinners no matter what!</em></div></a><a href="https://tampa.cbslocal.com/2020/05/13/the-most-searched-recipe-in-every-state-during-quarantine-coronavirus/" title="Coronavirus Cooking: The Most Searched Recipe In Every State During Quarantine" class="cbs-thumbnail-link item-1589398031 content-type-video" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://tampa.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://tampa.cbslocal.com/wp-content/uploads/sites/15909843/2020/05/QuarantineRecipesFeat.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Coronavirus Cooking: The Most Searched Recipe In Every State During Quarantine</strong><em class="description">Find the most popular eats for your home state and across the country during the coronavirus quarantine.</em></div></a><a href="https://tampa.cbslocal.com/2020/05/13/how-to-make-homemade-bagels-quarantine/" title="Quarantine Recipes: How To Make Homemade Bagels" class="cbs-thumbnail-link item-1589397541 content-type-video" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://tampa.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://tampa.cbslocal.com/wp-content/uploads/sites/15909843/2020/05/bagelfeat.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Quarantine Recipes: How To Make Homemade Bagels</strong><em class="description">See how to make your own homemade bagels while stuck inside during quarantine.</em></div></a>		</div>
	</section>
</div></div></li><li class="menu-top-item item-4 w-link w-submenu"><a href="http://tampa.cbslocal.com/category/sports/" title="Sports" class="cbs-thumbnail-link wo-hover" ><div class="title-wrapper"><strong class="title">Sports</strong></div></a><div class="submenu"><div class="wrapper">
<section class="items-grid column-count-2 block-type-wpmenu layout-compact aspect-ratio-16-9" id="" >
		<header class="column-header">
				<h4 class="title">View All Sports</h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="https://tampa.cbslocal.com/category/sports/" title="Latest" class="cbs-thumbnail-link item-0" ><div class="title-wrapper"><strong class="title">Latest</strong></div></a><a href="http://tampa.cbslocal.com/category/sports/rays/" title="Rays" class="cbs-thumbnail-link item-1" ><div class="title-wrapper"><strong class="title">Rays</strong></div></a><a href="http://www.cbssports.com/nfl/teams/page/TB/tampa-bay-buccaneers" title="Bucs" class="cbs-thumbnail-link item-2" ><div class="title-wrapper"><strong class="title">Bucs</strong></div></a><a href="http://tampa.cbslocal.com/category/sports/lightning/" title="Lightning" class="cbs-thumbnail-link item-3" ><div class="title-wrapper"><strong class="title">Lightning</strong></div></a><a href="http://www.cbssports.com/nfl/" title="NFL" class="cbs-thumbnail-link item-4" ><div class="title-wrapper"><strong class="title">NFL</strong></div></a><a href="http://www.cbssports.com/mlb/" title="MLB" class="cbs-thumbnail-link item-5" ><div class="title-wrapper"><strong class="title">MLB</strong></div></a><a href="http://www.cbssports.com/nba/" title="NBA" class="cbs-thumbnail-link item-6" ><div class="title-wrapper"><strong class="title">NBA</strong></div></a><a href="http://www.cbssports.com/nhl/" title="NHL" class="cbs-thumbnail-link item-7" ><div class="title-wrapper"><strong class="title">NHL</strong></div></a><a href="http://www.cbssports.com/college-football/" title="NCAAFB" class="cbs-thumbnail-link item-8" ><div class="title-wrapper"><strong class="title">NCAAFB</strong></div></a><a href="http://www.cbssports.com/college-basketball/" title="NCAAB" class="cbs-thumbnail-link item-9" ><div class="title-wrapper"><strong class="title">NCAAB</strong></div></a>		</div>
	</section>

<section class="items-grid enable-type-icons column-count-2 block-type-grid layout-3_column aspect-ratio-16-9" id="" >
		<header class="column-header">
				<h4 class="title">Featured Articles</h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="https://tampaprofootballknockout.cbslocal.com/" title="Make Your Pick!" class="cbs-thumbnail-link item-1600179355 content-type-video" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://tampa.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://tampa.cbslocal.com/wp-content/uploads/sites/15909843/2020/09/knockout-make-your-pick-1024x576-2.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Make Your Pick!</strong><em class="description">Registration for the Knockout Pool has closed. Make sure to make your pick for this week! This is a national contest. </em></div></a><a href="https://tampa.cbslocal.com/2020/09/11/dolphins-patriots-preview-cam-newton-tom-brady-afc-east/" title="Dolphins-Patriots Preview: Tom Brady&#039;s Departure Ushers In A New Era In New England" class="cbs-thumbnail-link item-1599859955" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://tampa.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://tampa.cbslocal.com/wp-content/uploads/sites/15909843/2020/09/cam-newton-patriots-1.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Dolphins-Patriots Preview: Tom Brady&#039;s Departure Ushers In A New Era In New England</strong><em class="description">The Miami Dolphins open up their season on the road against the New England Patriots as the balance of power in the AFC East shifts.</em></div></a>		</div>
	</section>

<section class="items-grid enable-type-icons column-count-2 block-type-grid layout-3_column aspect-ratio-16-9" id="" >
		<header class="column-header">
				<h4 class="title">Latest Galleries</h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="https://tampa.cbslocal.com/photo-galleries/2014/12/30/final-nfl-power-rankings/" title="Final NFL Power Rankings" class="cbs-thumbnail-link item-1419918619 content-type-photo" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://tampa.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://tampa.cbslocal.com/wp-content/uploads/sites/15909843/2014/12/460879088.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Final NFL Power Rankings</strong><em class="description">It&#039;s tough to keep up with all the action in NFL. Here&#039;s your final power rankings of the season.</em></div></a><a href="https://tampa.cbslocal.com/photo-galleries/2014/12/19/nfl-power-rankings-week-16/" title="NFL Power Rankings: Week 16" class="cbs-thumbnail-link item-1418966955 content-type-photo" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://tampa.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://tampa.cbslocal.com/wp-content/uploads/sites/15909843/2014/12/460465244.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">NFL Power Rankings: Week 16</strong><em class="description">It&#039;s tough to keep up with all the action in NFL. Here&#039;s your power rankings heading into Week 16.</em></div></a>		</div>
	</section>
</div></div></li><li class="menu-top-item item-5 w-link w-submenu"><a href="http://tampa.cbslocal.com/category/health/" title="Health" class="cbs-thumbnail-link wo-hover" ><div class="title-wrapper"><strong class="title">Health</strong></div></a><div class="submenu"><div class="wrapper"></div></div></li><li class="menu-top-item item-6 w-link w-submenu"><a href="http://tampa.cbslocal.com/category/contests/" title="Videos &amp; More" class="cbs-thumbnail-link wo-hover" ><div class="title-wrapper"><strong class="title">Videos &amp; More</strong></div></a><div class="submenu"><div class="wrapper">
<section class="items-grid column-count-1 block-type-wpmenu layout-compact aspect-ratio-16-9" id="" >
		<header class="column-header">
				<h4 class="title">Video</h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="https://tampa.cbslocal.com/live/cbsn-new-york/" title="CBSN NY" class="cbs-thumbnail-link item-0" ><div class="title-wrapper"><strong class="title">CBSN NY</strong></div></a><a href="https://tampa.cbslocal.com/live/cbsn/" title="CBSN" class="cbs-thumbnail-link item-1" ><div class="title-wrapper"><strong class="title">CBSN</strong></div></a><a href="https://tampa.cbslocal.com/live/cbs-sports-hq/" title="CBS Sports HQ" class="cbs-thumbnail-link item-2" ><div class="title-wrapper"><strong class="title">CBS Sports HQ</strong></div></a><a href="https://tampa.cbslocal.com/live/et-live/" title="ET Live" class="cbs-thumbnail-link item-3" ><div class="title-wrapper"><strong class="title">ET Live</strong></div></a>		</div>
	</section>
</div></div></li></ul></nav>
	
	
	<div id="info-search"><form action="https://tampa.cbslocal.com/search/" class="form"><input type="text" class="query" name="q" id="s" size="31" placeholder="Search..." /><input type="reset" class="reset" value="Reset" /><input type="submit" class="submit" value="&#xf002" /></form><span class="open-close" onclick="jQuery(document).ready(function(){jQuery('#info-search').toggleClass('open');});"></span></div>
</div></header>		<section class="page-ad-container page-pencil-ad-container-top">
			<div id="reptile_1_wrapper" class="ad-block-wrapper cbs-ad-unit-wrapper"><span id="ad_1"><div id="reptile_1" class="ad-block" data-ad_size="[[970,250],[970,66],[728,90]]" data-ad_location="top"><script>cbs_load_ad_by_tile("1");</script></div></span></div>		</section>
		
<div id="page-content" class="main-white page-block-container and-w-sidebar">
<header id="page-rubric" class="">

			<div class="banner-title-wrapper">
							<h1 class="title">Protesters Blame Clayton Co. Sheriff For Policing Issues</h1>
					</div>
	
	
	
	
	
</header>
<section class="page-columns"><section class="page-column three-column" id="article-entry-date-and-tags"><div class="column-header"><span class="post-subtitle">&#039;I&#039;m Coming For You, Hill&#039;: Roderick Walker&#039;s Attorney</span><time class="post-date">September 15, 2020 at 6:39 am</time><div class="column-header-metadata"><strong>Filed Under:</strong><span><a href="https://tampa.cbslocal.com/tag/arrest/">Arrest</a>, <a href="https://tampa.cbslocal.com/tag/attorney/">attorney</a>, <a href="https://tampa.cbslocal.com/tag/beaten/">beaten</a>, <a href="https://tampa.cbslocal.com/tag/clayton-county/">Clayton County</a>, <a href="https://tampa.cbslocal.com/tag/cw69-news-at-10/">CW69 News at 10</a>, <a href="https://tampa.cbslocal.com/tag/devin-barrington-ward/">Devin Barrington-Ward</a>, <a href="https://tampa.cbslocal.com/tag/roderick-walker/">Roderick Walker</a>, <a href="https://tampa.cbslocal.com/tag/shean-williams/">Shean Williams</a>, <a href="https://tampa.cbslocal.com/tag/sheriff-victor-hill/">Sheriff Victor Hill</a>, <a href="https://tampa.cbslocal.com/tag/sheriffs-office/">Sheriff&#039;s Office</a></div></div></section><section id="column_block_1" class="page-column and-content-column two-column"><div class="column-item story" id="main-story"><section class="column-item media-type-anvato  ratio-display" id="featured-media"><div id="floating-player-container" class="video-wrapper anvato"><div id="p0"></div><script>cbsoptanon.onScriptsReady(function(cmp){cmp.ot.targetingAllowed(function(a){if(a) AnvatoPlayer("p0").init({"mcp":"cbs","width":"100%","height":"100%","video":"4708998","autoplay":true,"titleVisible":false,"accessKey":"anvato_cbslocal_app_web_prod_547f3e49241ef0e5d30c79b2efbca5d92c698f67","accessControl":{"preview":false},"pInstance":"p0","plugins":{"dfp":{"clientSide":{"adTagUrl":"http:\/\/pubads.g.doubleclick.net\/gampad\/ads?sz=2x2&iu=\/4128\/CBS.TAMPA&ciu_szs&impl=s&gdfp_req=1&env=vp&output=xml_vast2&unviewed_position_start=1&url=[referrer_url]&description_url=[description_url]&correlator=[timestamp]","keyValues":{"categories":"[[CATEGORIES]]","program":"[[PROGRAM_NAME]]","siteSection":"featured"}}}},"shareLink":"https:\/\/cbsloc.al\/3bXzxxN","video-type":"featured","expectPreroll":true,"expectPrerollTimeout":5});});});</script></div></section>
<div class="main-story-wrapper"><p>ATLANTA, Ga. (CW69 News at 10) &#8212; Protesters and an attorney representing Roderick Walker, a man arrested and beaten by deputies during a traffic stop on September 11, 2020, say his arrest is drawing attention to bigger issues with the Clayton County Sheriff.</p>
<p>They blame <a href="https://www.facebook.com/ClaytonCountySheriffGA" target="_blank" rel="nofollow">Sheriff Victor Hill</a> for things they say led to what happened on that day: deputies pinning Walker down and punching him, before they arrested and charged him with battery and obstruction of officers.</p>
<p>&ldquo;I&rsquo;m putting you on notice. I&rsquo;m coming for you, Hill,&#8221; said Walker&#8217;s attorney, Shean Williams, while speaking at the protest. Williams is a partner with The Cochran Firm Atlanta.&nbsp;Williams says Walker cooperated during the traffic stop and simply asked the deputies why they wanted to see his ID if he was only a passenger in the vehicle.&nbsp;&ldquo;The deputies got upset and pulled him out and started assaulting him beating him, and as a result, tased him, choked him and he almost died,&#8221; Williams said.</p>
<p>Walker&rsquo;s supporters are demanding District Attorney Tasha Mosely dismiss the charges.&nbsp;Sheriff Hill fired one of the deputies involved for excessive use of force, but he has not identified the ones involved or provided any body camera footage.</p>
<blockquote class="twitter-tweet" data-width="420" data-dnt="true">
<p lang="en" dir="ltr"><a href="https://twitter.com/CochranFirm_ATL?ref_src=twsrc%5Etfw">@CochranFirm_ATL</a> confirmed tonight a $25,000 bond was set for Walker. <a href="https://t.co/YKZIcEfc87">pic.twitter.com/YKZIcEfc87</a></p>
<p>&mdash; Valencia E. Jones (@vjreports3) <a href="https://twitter.com/vjreports3/status/1305679406501945345?ref_src=twsrc%5Etfw">September 15, 2020</a></p></blockquote>
<p><script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script></p>
<p>This evening, The Cochran Firm Atlanta confirmed the District Attorney set a $25,000 bond for Walker. Hill has said the magistrate previously denied a signature bond, based on Walker&rsquo;s criminal record, which includes a felony probation warrant out of Fulton County for Cruelty to Children.&nbsp;Williams says his prior record is irrelevant.</p>
<p>&ldquo;He&rsquo;s a coward,&#8221; Williams said referring to Hill. &#8220;He wouldn&rsquo;t even tell you who the deputies are, but he&rsquo;s going to talk about my client. I think it&rsquo;s shameful and disgraceful.&rdquo;</p>
<p>Hill&rsquo;s time in office has been marred by several controversies and accusations of bullying residents.</p>
<p>Devin Barrington-Ward, an organizer with Movement For Black Lives Atlanta, said Hill is responsible for his agency&#8217;s &ldquo;unreasonable stops and search and seizures and road blocks,&#8221; and he said the Clayton County Jail is a hotbed for COVID-19.</p>
<p>&#8220;He&rsquo;s being sued,&#8221; said Barrington-Ward. &#8220;In addition to that, this sheriff has shot his ex-girlfriend and gotten away with it.&#8221;</p>
<p>Other protesters commented on the many incidents that have weighed heavily on Metro Atlanta and the nation this year alone, including the deaths of Breonna Taylor, Ahmaud Arbery, George Floyd and Rayshard Brooks.</p>
<p>&ldquo;The culture of policing needs to be changed,&#8221; said Jeremy McLeod, a Clayton County resident.&nbsp;&ldquo;I am tired of seeing Black men brutalized by the police. These are my brothers, these are my sisters,&#8221; said Alexis Muir, a protestor who lives in DeKalb County.</p>
<p>CW69 reached out to Sheriff Hill for comment on Walker&rsquo;s case and all the allegations. There was no immediate response. Hill is&nbsp;running unopposed for re-election in November.</p>
<div class="social-buttons">
	<div class="social-media-container vertical">
					<div class="social-share-items addthis_toolbox addthis_default_style addthis_32x32_style">
				<span><a class="addthis_button_facebook"  addthis:url="https://cbsloc.al/3bXzxxN"></a><a class="addthis_button_twitter"  addthis:url="https://cbsloc.al/3bXzxxN"></a><a href="#" class="addthis_button_linkedin"></a><a href="#" class="addthis_button_reddit"></a><a class="addthis_button_compact"  addthis:url="https://cbsloc.al/3bXzxxN"></a></span>
			</div>
		
			</div>
</div></div></div><div id="reptile_30_wrapper" class="ad-block-wrapper cbs-ad-unit-wrapper partner-container partner-sharethrough"><span id="ad_30"><div id="reptile_30" class="ad-block" data-ad_size="[[1,5]]" data-ad_location="partner-injected"><script>cbs_load_ad_by_tile("30");</script></div></span></div><div class="partner-container partner-taboola"><div id="taboola-block-2"></div></div></section><aside class="sidebar right-bar" rel="modular+"><div id="reptile_2_wrapper" class="ad-block-wrapper cbs-ad-unit-wrapper"><span id="ad_2"><div id="reptile_2" class="ad-block" data-ad_size="[[300,250],[300,600],[300,1050]]" data-ad_location="top"><script>cbs_load_ad_by_tile("2");</script></div></span></div><div id="" class="block sidebar-widget widget_cbs_follow_us_widget"><h3 class="title">Follow Us</h3>
		<div class="widget-content-wrapper">
			<a href="https://www.facebook.com/CBSTampaBay" target="_blank" title="facebook_url" class="cbs-thumbnail-link facebook_url" ><div class="title-wrapper"><strong class="title">facebook_url</strong></div></a><a href="https://twitter.com/CBSTampaBay" target="_blank" title="twitter_url" class="cbs-thumbnail-link twitter_url" ><div class="title-wrapper"><strong class="title">twitter_url</strong></div></a>		</div>

		</div><div id="" class="block sidebar-widget widget_top-posts"><h3 class="title"><span>Most </span> Viewed</h3><ul class='widgets-list-layout no-grav'>
					<li>
						<a href="https://tampa.cbslocal.com/2020/09/15/protesters-blame-clayton-co-sheriff-for-policing-issues/" title="Protesters Blame Clayton Co. Sheriff For Policing Issues" class="bump-view" data-bump-view="tp" aria-current="page">
								<img width="55" height="55" src="https://i1.wp.com/tampa.cbslocal.com/wp-content/uploads/sites/15909843/2020/09/Protest-Web.jpg?resize=55%2C55&#038;ssl=1" alt="Protesters Blame Clayton Co. Sheriff For Policing Issues" data-pin-nopin="true" class="widgets-list-layout-blavatar"/>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://tampa.cbslocal.com/2020/09/15/protesters-blame-clayton-co-sheriff-for-policing-issues/" title="Protesters Blame Clayton Co. Sheriff For Policing Issues" class="bump-view" data-bump-view="tp" aria-current="page">Protesters Blame Clayton Co. Sheriff For Policing Issues</a>
							</div>
													</li>
										<li>
						<a href="https://tampa.cbslocal.com/2020/09/13/developing-story-womans-body-found-in-waters-of-old-tampa-bay-7/" title="DEVELOPING STORY: Woman&#039;s Body Found In Waters Of Old Tampa Bay" class="bump-view" data-bump-view="tp">
								<img width="55" height="55" src="https://i1.wp.com/tampa.cbslocal.com/wp-content/uploads/sites/15909843/2020/09/Womans-Body-Found.jpg?resize=55%2C55&#038;ssl=1" alt="DEVELOPING STORY: Woman&#039;s Body Found In Waters Of Old Tampa Bay" data-pin-nopin="true" class="widgets-list-layout-blavatar"/>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://tampa.cbslocal.com/2020/09/13/developing-story-womans-body-found-in-waters-of-old-tampa-bay-7/" title="DEVELOPING STORY: Woman&#039;s Body Found In Waters Of Old Tampa Bay" class="bump-view" data-bump-view="tp">DEVELOPING STORY: Woman&#039;s Body Found In Waters Of Old Tampa Bay</a>
							</div>
													</li>
										<li>
						<a href="https://tampa.cbslocal.com/2020/09/15/trump-unemployment-300-benefit-jobless-aid-lost-wages-assistance/" title="Trump&#039;s Additional $300 Unemployment Benefits Could Now Last Up To Six Weeks" class="bump-view" data-bump-view="tp">
								<img width="55" height="55" src="https://i0.wp.com/tampa.cbslocal.com/wp-content/uploads/sites/15909843/2020/09/unemployment-line-1.jpg?resize=55%2C55&#038;ssl=1" alt="Trump&#039;s Additional $300 Unemployment Benefits Could Now Last Up To Six Weeks" data-pin-nopin="true" class="widgets-list-layout-blavatar"/>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://tampa.cbslocal.com/2020/09/15/trump-unemployment-300-benefit-jobless-aid-lost-wages-assistance/" title="Trump&#039;s Additional $300 Unemployment Benefits Could Now Last Up To Six Weeks" class="bump-view" data-bump-view="tp">Trump&#039;s Additional $300 Unemployment Benefits Could Now Last Up To Six Weeks</a>
							</div>
													</li>
										<li>
						<a href="https://tampa.cbslocal.com/2020/09/13/breaking-4-victims-in-overnight-shooting-at-club-1828-in-tampa-9/" title="UPDATE: 4 Victims In Overnight Shooting At Club 1828 In Tampa" class="bump-view" data-bump-view="tp">
								<img width="55" height="55" src="https://i0.wp.com/tampa.cbslocal.com/wp-content/uploads/sites/15909843/2020/09/OvernightShooting_Tampa.jpg?resize=55%2C55&#038;ssl=1" alt="UPDATE: 4 Victims In Overnight Shooting At Club 1828 In Tampa" data-pin-nopin="true" class="widgets-list-layout-blavatar"/>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://tampa.cbslocal.com/2020/09/13/breaking-4-victims-in-overnight-shooting-at-club-1828-in-tampa-9/" title="UPDATE: 4 Victims In Overnight Shooting At Club 1828 In Tampa" class="bump-view" data-bump-view="tp">UPDATE: 4 Victims In Overnight Shooting At Club 1828 In Tampa</a>
							</div>
													</li>
										<li>
						<a href="https://tampa.cbslocal.com/2020/09/08/florida-teacher-arrested-for-distribution-of-child-porn-1/" title="Florida Teacher Arrested For Distribution Of Child Sexual Porn" class="bump-view" data-bump-view="tp">
								<img width="55" height="55" src="https://i2.wp.com/tampa.cbslocal.com/wp-content/uploads/sites/15909843/2019/08/FBmessenger.jpg?resize=55%2C55&#038;ssl=1" alt="Florida Teacher Arrested For Distribution Of Child Sexual Porn" data-pin-nopin="true" class="widgets-list-layout-blavatar"/>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://tampa.cbslocal.com/2020/09/08/florida-teacher-arrested-for-distribution-of-child-porn-1/" title="Florida Teacher Arrested For Distribution Of Child Sexual Porn" class="bump-view" data-bump-view="tp">Florida Teacher Arrested For Distribution Of Child Sexual Porn</a>
							</div>
													</li>
										<li>
						<a href="https://tampa.cbslocal.com/2020/09/12/alleged-tampa-gang-leader-sentenced-to-more-than-23-years-in-prison-10/" title="Alleged Tampa Gang Leader Sentenced To More Than 23 Years In Prison" class="bump-view" data-bump-view="tp">
								<img width="55" height="55" src="https://i2.wp.com/tampa.cbslocal.com/wp-content/uploads/sites/15909843/2020/09/Sentenced.jpg?resize=55%2C55&#038;ssl=1" alt="Alleged Tampa Gang Leader Sentenced To More Than 23 Years In Prison" data-pin-nopin="true" class="widgets-list-layout-blavatar"/>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://tampa.cbslocal.com/2020/09/12/alleged-tampa-gang-leader-sentenced-to-more-than-23-years-in-prison-10/" title="Alleged Tampa Gang Leader Sentenced To More Than 23 Years In Prison" class="bump-view" data-bump-view="tp">Alleged Tampa Gang Leader Sentenced To More Than 23 Years In Prison</a>
							</div>
													</li>
										<li>
						<a href="https://tampa.cbslocal.com/2020/09/11/tampa-police-searching-for-man-that-robbed-mcdonalds-in-hyde-park-7/" title="Tampa Police Searching For Man That Robbed McDonald&#039;s In Hyde Park" class="bump-view" data-bump-view="tp">
								<img width="55" height="55" src="https://i1.wp.com/tampa.cbslocal.com/wp-content/uploads/sites/15909843/2020/09/McDonalds-Robbery-On-Kennedy-Blvd-In-Hyde-Park-Tampa.jpg?resize=55%2C55&#038;ssl=1" alt="Tampa Police Searching For Man That Robbed McDonald&#039;s In Hyde Park" data-pin-nopin="true" class="widgets-list-layout-blavatar"/>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://tampa.cbslocal.com/2020/09/11/tampa-police-searching-for-man-that-robbed-mcdonalds-in-hyde-park-7/" title="Tampa Police Searching For Man That Robbed McDonald&#039;s In Hyde Park" class="bump-view" data-bump-view="tp">Tampa Police Searching For Man That Robbed McDonald&#039;s In Hyde Park</a>
							</div>
													</li>
										<li>
						<a href="https://tampa.cbslocal.com/2020/09/11/retired-clearwater-officer-arrested-for-molestation-of-a-12-year-old-4/" title="Retired Clearwater Officer Arrested For Molestation Of A 12-Year-Old" class="bump-view" data-bump-view="tp">
								<img width="55" height="55" src="https://i0.wp.com/tampa.cbslocal.com/wp-content/uploads/sites/15909843/2020/07/iStock-1144135834-e1599840762455.jpg?resize=55%2C55&#038;ssl=1" alt="Retired Clearwater Officer Arrested For Molestation Of A 12-Year-Old" data-pin-nopin="true" class="widgets-list-layout-blavatar"/>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://tampa.cbslocal.com/2020/09/11/retired-clearwater-officer-arrested-for-molestation-of-a-12-year-old-4/" title="Retired Clearwater Officer Arrested For Molestation Of A 12-Year-Old" class="bump-view" data-bump-view="tp">Retired Clearwater Officer Arrested For Molestation Of A 12-Year-Old</a>
							</div>
													</li>
										<li>
						<a href="https://tampa.cbslocal.com/2020/06/13/jason-allgair-steinbrenner-high-school-band-teacher-accused-of-sexual-misconduct-with-student-5/" title="Jason Allgair, Steinbrenner High School Band Teacher Accused Of Sexual Misconduct With Student" class="bump-view" data-bump-view="tp">
								<img width="55" height="55" src="https://i0.wp.com/tampa.cbslocal.com/wp-content/uploads/sites/15909843/2020/06/JasonAllgair_Arrest_HCSO.jpg?resize=55%2C55&#038;ssl=1" alt="Jason Allgair, Steinbrenner High School Band Teacher Accused Of Sexual Misconduct With Student" data-pin-nopin="true" class="widgets-list-layout-blavatar"/>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://tampa.cbslocal.com/2020/06/13/jason-allgair-steinbrenner-high-school-band-teacher-accused-of-sexual-misconduct-with-student-5/" title="Jason Allgair, Steinbrenner High School Band Teacher Accused Of Sexual Misconduct With Student" class="bump-view" data-bump-view="tp">Jason Allgair, Steinbrenner High School Band Teacher Accused Of Sexual Misconduct With Student</a>
							</div>
													</li>
										<li>
						<a href="https://tampa.cbslocal.com/2020/09/11/2-correctional-officers-charged-with-burglary-battery-in-winter-haven-8/" title="2 Correctional Officers Charged With Burglary &amp; Battery In Winter Haven" class="bump-view" data-bump-view="tp">
								<img width="55" height="55" src="https://i1.wp.com/tampa.cbslocal.com/wp-content/uploads/sites/15909843/2020/09/Winter-Haven-Home-Invasion-Hardee-County-Correctional-Officers_Arrest-Wanted.jpg?resize=55%2C55&#038;ssl=1" alt="2 Correctional Officers Charged With Burglary &amp; Battery In Winter Haven" data-pin-nopin="true" class="widgets-list-layout-blavatar"/>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://tampa.cbslocal.com/2020/09/11/2-correctional-officers-charged-with-burglary-battery-in-winter-haven-8/" title="2 Correctional Officers Charged With Burglary &amp; Battery In Winter Haven" class="bump-view" data-bump-view="tp">2 Correctional Officers Charged With Burglary &amp; Battery In Winter Haven</a>
							</div>
													</li>
					</ul>
</div><div id="reptile_31_wrapper" class="ad-block-wrapper cbs-ad-unit-wrapper big-right-ad sidebar-adhesive-ad"><span id="ad_31"><div id="reptile_31" class="ad-block" data-ad_size="[[300,250]]" data-ad_location="adhesion"><script>cbs_load_ad_by_tile("31");</script></div></span></div></aside></section>		<section class="page-ad-container page-pencil-ad-container-bottom">
			<div id="reptile_4_wrapper" class="ad-block-wrapper cbs-ad-unit-wrapper"><span id="ad_4"><div id="reptile_4" class="ad-block" data-ad_size="[[728,90]]" data-ad_location="bottom"><script>cbs_load_ad_by_tile("4");</script></div></span></div>		</section>
		

</div>


<footer id="page-footer" class="page-footer-type-menus-vertical">
			<section class="top"><div class="wrapper">
										<div id="component-social" class="footer-component social-follow-items type-blue size-24x24">
					<div class="social-align-wrapper">
						<span class="disclosure">Follow Us</span>
						<a href="https://www.facebook.com/CBSTampaBay" class="facebook" target="_blank">Facebook</a><a href="https://twitter.com/CBSTampaBay" class="twitter" target="_blank">Twitter</a>					</div>
				</div>
					</div></section>
	
			<section class="middle"><div class="wrapper">
			
<section class="items-grid block-menu layout-compact aspect-ratio-16-9" id="block-0" >
		<header class="column-header">
				<h4 class="title">Entertainment</h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="https://tampa.cbslocal.com/category/only-cbs/" title="Only CBS" class="cbs-thumbnail-link item-0" ><div class="title-wrapper"><strong class="title">Only CBS</strong></div></a><a href="/category/best-of/" title="Best Of" class="cbs-thumbnail-link item-1" ><div class="title-wrapper"><strong class="title">Best Of</strong></div></a><a href="https://tampa.cbslocal.com/category/travel/" title="Travel" class="cbs-thumbnail-link item-2" ><div class="title-wrapper"><strong class="title">Travel</strong></div></a><a href="http://cwtampa.cbslocal.com/" title="CW44" class="cbs-thumbnail-link item-3" ><div class="title-wrapper"><strong class="title">CW44</strong></div></a>		</div>
	</section>

<section class="items-grid block-menu layout-compact aspect-ratio-16-9" id="block-1" >
		<header class="column-header">
				<h4 class="title">Corporate</h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="http://tampa.cbslocal.com/about-us/" title="About Us" class="cbs-thumbnail-link item-0" ><div class="title-wrapper"><strong class="title">About Us</strong></div></a><a href="http://tampa.cbslocal.com/about-us/advertising-basics/" title="Advertise" class="cbs-thumbnail-link item-1" ><div class="title-wrapper"><strong class="title">Advertise</strong></div></a><a href="https://cwtampa.cbslocal.com/contactus/" title="Contact Us" class="cbs-thumbnail-link item-2" ><div class="title-wrapper"><strong class="title">Contact Us</strong></div></a>		</div>
	</section>
		</div></section>
	
			<section class="bottom"><div class="wrapper">
			<a href="https://tampa.cbslocal.com" class="logo"><img src="https://tampa.cbslocal.com/wp-content/themes/cbs-local/plugins/modules/theme-manager/images/cbs-local-logo-white.png" alt="CBS Tampa" /></a>
			<div class="copyright-wrapper">
				<span class="copyright">&copy;2020 CBS Broadcasting Inc. All Rights Reserved.</span>
									<span class="powered-by-wordpress">Powered by <a href="https://wpvip.com/?utm_source=vip_powered_wpcom&#038;utm_medium=web&#038;utm_campaign=VIP%20Footer%20Credit&#038;utm_term=tampa.cbslocal.com" rel="generator nofollow" class="powered-by-wpcom">WordPress.com VIP</a></span>
							</div>

			<div class="right-wrapper">
									<div class="terms-of-use">By viewing our video content, you are accepting the terms of our <a href="https://privacy.cbs/videoservices" target="_blank" title="Video Services Policy">Video Services Policy</a></div>
								<ul id="menu-final-footer-menu" class="nav-final-footer"><li id="menu-item-44045" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-44045"><a href="http://policies.cbslocal.com/privacy/current.html">Privacy Policy</a></li>
<li id="menu-item-44046" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-44046"><a href="http://policies.cbslocal.com/terms-of-use">Terms of Use</a></li>
<li id="menu-item-172019" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-172019"><a href="https://publicfiles.fcc.gov/tv-profile/wtog">Public File for WTOG-TV / CW 44</a></li>
<li id="menu-item-208371" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-208371"><a href="https://cwtampa.cbslocal.com/wp-content/uploads/sites/31326193/2019/09/EEO-10-1-2018-to-9-30-2019.pdf">Public File Contact Us for WTOG-TV / CW 44</a></li>
<li id="menu-item-218783" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-218783"><a href="https://ca.privacy.cbs">California Privacy/Info We Collect</a></li>
<li id="menu-item-218784" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-218784"><a href="https://ca.privacy.cbs/donotsell">California Do Not Sell My Info</a></li>
<li id="menu-item-161080" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-161080"><a href="http://policies.cbslocal.com/mobile-app-agreement/">Mobile User Agreement</a></li>
<li id="menu-item-77985" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-77985"><a href="http://policies.cbslocal.com/privacy/current.html#onlinead">Ad Choices</a></li>
</ul>			</div>

						</div></section>
</footer>

<!--PARTNER SCRIPTS START-->
<div id="reptile_32_wrapper" class="ad-block-wrapper cbs-ad-unit-wrapper pixel-ad"><span id="ad_32"><div id="reptile_32" class="ad-block" data-ad_size="[[1,8]]" data-ad_location=""><script>cbs_load_ad_by_tile("32");</script></div></span></div><div id="reptile_33_wrapper" class="ad-block-wrapper cbs-ad-unit-wrapper pixel-ad"><span id="ad_33"><div id="reptile_33" class="ad-block" data-ad_size="[[1,6]]" data-ad_location=""><script>cbs_load_ad_by_tile("33");</script></div></span></div><div id="reptile_34_wrapper" class="ad-block-wrapper cbs-ad-unit-wrapper pixel-ad"><span id="ad_34"><div id="reptile_34" class="ad-block" data-ad_size="[[1,7]]" data-ad_location=""><script>cbs_load_ad_by_tile("34");</script></div></span></div>
<!--PARTNER SCRIPTS END-->


</div>

<link rel='stylesheet' id='all-css-0' href='https://tampa.cbslocal.com/wp-content/themes/cbs-local/plugins/modules/partners/css/partners.css?m=1579025881g' type='text/css' media='all' />
<script type='text/javascript' src='https://tampa.cbslocal.com/wp-includes/js/wp-embed.min.js?m=1598987401g'></script>
<script src='https://w3.cdn.anvato.net/player/prod/v3/scripts/anvload.js?ver=5.5.1' id='cbs-cbs-anvato-js'></script>
<script type='text/javascript' src='https://stats.wp.com/e-202038.js' async='async' defer='defer'></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:8.9',blog:'162238304',post:'229900',tz:'-4',srv:'tampa.cbslocal.com'} ]);
	_stq.push([ 'clickTrackerInit', '162238304', '229900' ]);
</script>



<script type="text/javascript">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</script>

	
	
	
	
<script type="text/javascript">window.NREUM||(NREUM={});NREUM.info={"beacon":"bam.nr-data.net","licenseKey":"103fa8ca15","applicationID":"144794115","transactionName":"ZwdaZBdUX0VTVEBRC15NeVMRXF5YHV5aXAFI","queueTime":0,"applicationTime":264,"atts":"S0BNEl9OTBoQVhYCH00f","errorBeacon":"bam.nr-data.net","agent":""}</script></body>
</html>