<!DOCTYPE html>
<html lang="en-US">
<head>
	<meta charset="UTF-8" />
	<link rel="pingback" href="https://tampa.cbslocal.com/xmlrpc.php" />

<!-- WP Header - Start -->
<meta name="news_keywords" content="joel mchale, the twilight zone, joel mchale the twilight zone, jordan peele, joel mchale community" />
<meta name="keywords" content="joel mchale, the twilight zone, joel mchale the twilight zone, jordan peele, joel mchale community" />
<title>&#8216;It Was A Dream Come True, I Can&#8217;t Believe It&#8217;: Joel McHale On CBS All Access&#8217;s &#8216;The Twilight Zone&#8217; &#8211; CBS Tampa</title>
<!-- Jetpack Site Verification Tags -->
<meta name="google-site-verification" content="44caXBf4kjHeKKAT7ZZ89NaCX25utL_yRSa-qGpwIhY" />
<link rel="dns-prefetch" href="//cdn.cookielaw.org" />
<script type="text/javascript" charset="UTF-8" src="https://cdn.cookielaw.org/scripttemplates/otSDKStub.js" data-domain-script="7547764e-53b9-4fff-aef7-ce9cb429c721"></script>
<link rel="dns-prefetch" href="//production-cmp.isgprivacy.cbsi.com" />
<script type="text/javascript" charset="UTF-8" src="https://production-cmp.isgprivacy.cbsi.com/dist/optanon-v1.1.0.js"></script>
<script type="text/javascript">!function(n){var o=window,a="cbsoptanon",c="cmd",d="config";o[a]=o[a]?o[a]:{},o[a][c]=o[a][c]?o[a][c]:[],o[a][d]=o[a][d]?o[a][d]:[],["onScriptsReady","onAdsReady"].forEach(function(n){o[a][n]=o[a][n]||function(){var d=arguments;o[a][c].push(function(){o[a][n].apply(o[a],d)})}})}();</script>
<link rel='dns-prefetch' href='//maxcdn.bootstrapcdn.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="CBS Tampa &raquo; Feed" href="https://tampa.cbslocal.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="CBS Tampa &raquo; Comments Feed" href="https://tampa.cbslocal.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="CBS Tampa &raquo; &#8216;It Was A Dream Come True, I Can&#8217;t Believe It&#8217;: Joel McHale On CBS All Access&#8217;s &#8216;The Twilight Zone&#8217; Comments Feed" href="https://tampa.cbslocal.com/2020/07/27/joel-mchale-the-twilight-zone-interview/feed/" />
<link rel='stylesheet' id='all-css-0' href='https://tampa.cbslocal.com/_static/??-eJytj0sOwjAMRC9EsKpSBAvEWfIxJapjR/mI6xNSNqygEivbY7/RGB5RWeGCXKDcMWAGa7IisZrAs6XqXlLOcBMpmPat3cFPEAaDbmVjQhLtvsOR6uw5QxBXqW3026DV7XA/UEGznjF1mw9FtZBLkbjhpdWjBsPakyLPy/9TIbWJS//3Gi7DdBrG4+E8Tk91nZ9e' type='text/css' media='all' />
<link crossorigin="anonymous" rel='stylesheet' id='cbs-font-awesome-css'  href='//maxcdn.bootstrapcdn.com/font-awesome/4.7.0/css/font-awesome.min.css?ver=4.7.0' media='all' />
<link crossorigin="anonymous" rel='stylesheet' id='cbs-lato-font-css'  href='https://fonts.googleapis.com/css?family=Lato%3A300%2C400%2C700%2C900&#038;ver=1.0.0' media='all' />
<link rel='stylesheet' id='all-css-4' href='https://tampa.cbslocal.com/_static/??-eJytU9FOwzAM/CFCQIzBHhDfkqZWF+rEUeyu6t8vKd2qsYm1iDfH9p191kX3UVkKAkG07MEDa1uxQrIGNcuA8GiZH/RvbS5Y7OqSYtbRNKAEfEQjC7AFApiTQfh+d8SucYG1p7rDXBkblDchD00jlwwRNitX7l09r7xgix9601825z0lsXRimZ8rxoOvoP7Gj6FCx6KsEYPUrJSRVTiLoA7z8S7qdabWVQa2eUqVTBomd3gX1qvPF29Aztcv8RWJ79QJ9gUSjW2v4EJRReIcLXTqff94k9pCPbmTkNK/+PKSlw6Q+uRufJAbqgt8ikv7p/94ft1tXp5227f3IzMXaP0=' type='text/css' media='all' />
<style id='wp-block-library-inline-css'>
.has-text-align-justify{text-align:justify;}
</style>
<script type='text/javascript' src='https://tampa.cbslocal.com/_static/??-eJy1UNEOwiAM/CGRTGPUB+O3MKjYWcocZcv+Xlx80Cc3E18obe+u1+qhVTayAIuWKwRI2tZJUbSGNLKl7EqpSbqNNF6QaB2Q101a6bnEZhajpeyRkw7RZSod4yZyCarfvCt8SN8zdOMrfAWogL4zAj/5mQAqGDYeuqf0R0GVeTeJ7aLDXDJbwcjpH4aASsaSFjky7goJ+3kXKnhPsTa0bEQnaAkWrzug8yCTxOtbJM7hVO2O1WFb3n3zAHYdCoI='></script>
<link rel='https://api.w.org/' href='https://tampa.cbslocal.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://tampa.cbslocal.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://tampa.cbslocal.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 5.4.2" />
<link rel='shortlink' href='https://cbsloc.al/39xI6xW' />
<link rel="alternate" type="application/json+oembed" href="https://tampa.cbslocal.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Ftampa.cbslocal.com%2F2020%2F07%2F27%2Fjoel-mchale-the-twilight-zone-interview%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://tampa.cbslocal.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Ftampa.cbslocal.com%2F2020%2F07%2F27%2Fjoel-mchale-the-twilight-zone-interview%2F&#038;format=xml" />

<link rel='dns-prefetch' href='//v0.wordpress.com'/>
<link rel='dns-prefetch' href='//jetpack.wordpress.com'/>
<link rel='dns-prefetch' href='//s0.wp.com'/>
<link rel='dns-prefetch' href='//s1.wp.com'/>
<link rel='dns-prefetch' href='//s2.wp.com'/>
<link rel='dns-prefetch' href='//public-api.wordpress.com'/>
<link rel='dns-prefetch' href='//0.gravatar.com'/>
<link rel='dns-prefetch' href='//1.gravatar.com'/>
<link rel='dns-prefetch' href='//2.gravatar.com'/>
<style type='text/css'>img#wpstats{display:none}</style>
<meta property="og:title" content="&#039;It Was A Dream Come True, I Can&#039;t Believe It&#039;: Joel McHale On CBS All Access&#039;s &#039;The Twilight Zone&#039;" /><meta property="og:image" content="https://tampa.cbslocal.com/wp-content/uploads/sites/15909843/2020/07/116825_0135b-e1595867991666.jpg?w=1025" /><meta property="og:image:secure_url" content="https://tampa.cbslocal.com/wp-content/uploads/sites/15909843/2020/07/116825_0135b-e1595867991666.jpg?w=1025" /><meta property="og:image:width" content="1025" /><meta property="og:image:height" content="684" /><meta property="og:description" content="The actor and comedian discusses his role on the new season of &quot;The Twilight Zone&quot; on CBS All Access." /><meta property="og:type" content="article" /><meta property="og:url" content="https://tampa.cbslocal.com/2020/07/27/joel-mchale-the-twilight-zone-interview/" /><meta property="article:published_time" content="2020-07-27T13:03:58+00:00" /><meta property="article:suggested-social-copy" content="The actor and comedian discusses his role on the new season of &quot;The Twilight Zone&quot; on CBS All Access." /><meta property="article:opinion" content="false" /><meta property="article:content_tier" content="free" /><meta property="og:category" content="Entertainment News,Only CBS" /><meta property="article:publisher" content="https://www.facebook.com/CBSTampaBay" /><meta property="article:author" content="https://www.facebook.com/CBSTampaBay" />

<meta name="twitter:card" content="summary_large_image"/><meta name="twitter:image" content="https://tampa.cbslocal.com/wp-content/uploads/sites/15909843/2020/07/116825_0135b-e1595867991666.jpg?w=1025"><meta name="twitter:title" content="&#039;It Was A Dream Come True, I Can&#039;t Believe It&#039;: Joel McHale On CBS All Access&#039;s &#039;The Twilight Zone&#039;"/><meta name="twitter:description" content="The actor and comedian discusses his role on the new season of &quot;The Twilight Zone&quot; on CBS All Access."/><meta name="twitter:site" content="/CBSTampaBay"/>
<link rel="canonical" href="https://tampa.cbslocal.com/2020/07/27/joel-mchale-the-twilight-zone-interview/" />
				<style>
					.main-story-wrapper .basicsection { margin-bottom: 20px; }
					.main-story-wrapper .basicsection span strong { display: block; font-size: 18px; margin: 0 auto 15px; }
					.main-story-wrapper .basicsection img { float: none !important; margin: 0 auto 15px; }
					.main-story-wrapper .basicsection br { margin-bottom: 5px; }
				</style>
			<link rel="amphtml" href="https://tampa.cbslocal.com/2020/07/27/joel-mchale-the-twilight-zone-interview/amp/">
<script type="application/ld+json">{"@context":"http:\/\/schema.org","@type":"NewsArticle","publisher":{"@context":"http:\/\/schema.org","@type":"NewsMediaOrganization","@id":"https:\/\/tampa.cbslocal.com","url":"https:\/\/tampa.cbslocal.com","name":"CBS Tampa","foundingDate":"1941-07-01T14:30:00+00:00","logo":{"@type":"ImageObject","url":"https:\/\/tampa.cbslocal.com\/wp-content\/uploads\/sites\/15909843\/2018\/07\/2_cbs_tampabay.png?w=257"}},"url":"https:\/\/tampa.cbslocal.com\/2020\/07\/27\/joel-mchale-the-twilight-zone-interview\/","mainEntityOfPage":{"@type":"WebPage","@id":"https:\/\/tampa.cbslocal.com\/2020\/07\/27\/joel-mchale-the-twilight-zone-interview\/"},"headline":"&#8216;It Was A Dream Come True, I Can&#8217;t Believe It&#8217;: Joel McHale On CBS All Access&#8217;s &#8216;The Twilight Zone&#8217;","description":"The actor and comedian discusses his role on the new season of \"The Twilight Zone\" on CBS All Access.","image":"https:\/\/tampa.cbslocal.com\/wp-content\/uploads\/sites\/15909843\/2020\/07\/116825_0135b-e1595867991666.jpg?w=150&#038;h=150&#038;crop=1","keywords":["Entertainment News","Only CBS","CBS All Access","DJ Sixsmith","Joel McHale","Jordan Peele","the twilight zone","'It Was A Dream Come True, I Can't Believe It': Joel McHale On CBS All Access's 'The Twilight Zone'"],"datePublished":"2020-07-27T13:03:58+00:00","dateModified":"2020-07-27T13:03:58+00:00"}</script>
<script>cbs_lib.load_script("//launch.newsinc.com/js/embed.js");</script><script type="text/javascript">cbs_ads.partners.add("amazon", "3063");if(!window["apstag"]){window["apstag"]={init:function(){window["apstag"]._Q.push(["i",arguments]);},fetchBids:function(){window["apstag"]._Q.push(["f",arguments]);},setDisplayBids:function(){},_Q:[]};}</script>

<script type="text/javascript">cbs_ads.partners.add("sharethrough", true);</script>
<script>cbs_ads.init("4128","CBS.TAMPA","default",["itwasadreamcometrueicantbelieveitjoelmchaleoncbsallaccesssthetwilightzone","post","article","entertainmentnews","onlycbs","cbsallaccess","djsixsmith","joelmchale","jordanpeele","thetwilightzone","featuredvideo"],{"page_type":"article"});cbs_ads.refresh.set_timer("1");</script>

<link rel="dns-prefetch" href="//www.googletagmanager.com" />
<script type="text/plain" class="optanon-category-4" src="https://www.googletagmanager.com/gtag/js?id=UA-127524872-2" async></script>
<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=UA-127524872-2" height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
<script type="text/plain" class="optanon-category-4">window.dataLayer=window.dataLayer || [];function gtag(){dataLayer.push(arguments);}gtag("js",new Date());gtag("set",{"dimension1":"entertainment-news;only-cbs;","dimension2":"article"});gtag("config","UA-127524872-2");</script>

		<style type="text/css" id="wp-custom-css">
			.single-post sup {
	vertical-align: super;
	font-size: 10px;
}		</style>
		<!-- WP Header - End -->

	<meta name="description" content="The actor and comedian discusses his role on the new season of &quot;The Twilight Zone&quot; on CBS All Access." />
<script>//<![CDATA[
//]]></script>

</head>

<body class="post-template-default single single-post postid-227671 single-format-standard desktop-display-type  and-temp-wide"><div id="wrapper" class="body-wrapper">

<div id="reptile_skin_1" class="cbs-ad-unit ad_gpt cbs-ad-skin" data-ad_location="skin"><script>cbs_load_skin_by_tile(1);</script></div><header id="page-header" class=""><div class="wrapper">

				<a href="https://tampa.cbslocal.com" id="header-logo"><img src="https://tampa.cbslocal.com/wp-content/uploads/sites/15909843/2018/07/2_cbs_tampabay.png?w=257" alt="CBS Tampa" /></a>
	
	<nav id="navigation-main" data-item-count="7"><ul class="top"><li class="menu-top-item item-0 section-item"><div class="cbs-thumbnail-link wo-hover" ><div class="title-wrapper"><strong class="title">Menu</strong></div></div></li><li class="menu-top-item item-1 w-link"><a href="http://cwtampa.cbslocal.com/" title="CW44" class="cbs-thumbnail-link wo-hover" ><div class="title-wrapper"><strong class="title">CW44</strong></div></a></li><li class="menu-top-item item-2 w-link w-submenu"><a href="http://tampa.cbslocal.com/category/news/" title="News" class="cbs-thumbnail-link wo-hover" ><div class="title-wrapper"><strong class="title">News</strong></div></a><div class="submenu"><div class="wrapper">
<section class="items-grid column-count-2 block-type-wpmenu layout-compact aspect-ratio-16-9" id="" >
		<header class="column-header">
				<h4 class="title">View All News</h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="/category/news" title="Latest News" class="cbs-thumbnail-link item-0" ><div class="title-wrapper"><strong class="title">Latest News</strong></div></a><a href="https://tampa.cbslocal.com/business-news/" title="Business" class="cbs-thumbnail-link item-1" ><div class="title-wrapper"><strong class="title">Business</strong></div></a><a href="http://tampa.cbslocal.com/category/cw44-news/" title="CW44 News At 10" class="cbs-thumbnail-link item-2" ><div class="title-wrapper"><strong class="title">CW44 News At 10</strong></div></a><a href="https://tampa.cbslocal.com/entertainment-news/" title="Entertainment" class="cbs-thumbnail-link item-3" ><div class="title-wrapper"><strong class="title">Entertainment</strong></div></a><a href="https://tampa.cbslocal.com/cnet-tech-news/" title="CNET Tech News" class="cbs-thumbnail-link item-4" ><div class="title-wrapper"><strong class="title">CNET Tech News</strong></div></a><a href="http://tampa.cbslocal.com/category/travel/" title="Travel" class="cbs-thumbnail-link item-5" ><div class="title-wrapper"><strong class="title">Travel</strong></div></a><a href="http://tampa.cbslocal.com/category/health/" title="Health" class="cbs-thumbnail-link item-6" ><div class="title-wrapper"><strong class="title">Health</strong></div></a><a href="https://tampa.cbslocal.com/category/only-cbs/" title="Only CBS" class="cbs-thumbnail-link item-7" ><div class="title-wrapper"><strong class="title">Only CBS</strong></div></a>		</div>
	</section>

<section class="items-grid enable-type-icons column-count-2 block-type-grid layout-3_column aspect-ratio-16-9" id="" >
		<header class="column-header">
				<h4 class="title">Featured Articles</h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="https://tampa.cbslocal.com/2020/07/27/armed-career-criminal-sentenced-to-15-years-for-possessing-a-firearm-and-ammunition/" title="Armed Career Criminal Sentenced To 15 Years For Possessing A Firearm And Ammunition" class="cbs-thumbnail-link item-1595881589" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://tampa.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://tampa.cbslocal.com/wp-content/uploads/sites/15909843/2020/07/hand-gun.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Armed Career Criminal Sentenced To 15 Years For Possessing A Firearm And Ammunition</strong><em class="description">Armed Career Criminal Sentenced To 15 years for possessing a firearm and ammunition.</em></div></a><a href="https://tampa.cbslocal.com/2020/07/27/gwinnett-police-release-last-living-photos-burned-body/" title="Gwinnett Police Release Last Living Photos Of Man Found Burned" class="cbs-thumbnail-link item-1595878173" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://tampa.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://tampa.cbslocal.com/wp-content/uploads/sites/15909843/2020/07/Raul-Zapata-Garcia.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Gwinnett Police Release Last Living Photos Of Man Found Burned</strong><em class="description">Gwinnett County Police detectives have released the last known photos of a man whose body was found burned on a Duluth wooded trail.  These photos were taken at a convenience store prior to the murder.</em></div></a>		</div>
	</section>

<section class="items-grid enable-type-icons column-count-2 block-type-grid layout-3_column aspect-ratio-16-9" id="" >
		<header class="column-header">
				<h4 class="title">Galleries</h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="https://tampa.cbslocal.com/photo-galleries/2020/01/26/62nd-annual-grammy-awards-red-carpet-gallery/" title="62nd Annual GRAMMY Awards Red Carpet Gallery" class="cbs-thumbnail-link item-1580080563 content-type-photo" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://tampa.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://tampa.cbslocal.com/wp-content/uploads/sites/15909843/2020/01/GettyImages-1202147976.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">62nd Annual GRAMMY Awards Red Carpet Gallery</strong><em class="description">The best looks from the 62nd annual GRAMMY Awards on CBS.</em></div></a><a href="https://tampa.cbslocal.com/photo-galleries/2019/07/01/apollo-11-the-eagle-has-landed/" title="Apollo 11: &#039;The Eagle Has Landed&#039;" class="cbs-thumbnail-link item-1561957201 content-type-photo" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://tampa.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://tampa.cbslocal.com/wp-content/uploads/sites/15909843/2019/06/apollofeat.png?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Apollo 11: &#039;The Eagle Has Landed&#039;</strong></div></a>		</div>
	</section>
</div></div></li><li class="menu-top-item item-3 w-link w-submenu"><a href="http://tampa.cbslocal.com/category/best-of" title="Best Of" class="cbs-thumbnail-link wo-hover" ><div class="title-wrapper"><strong class="title">Best Of</strong></div></a><div class="submenu"><div class="wrapper">
<section class="items-grid enable-type-icons column-count-6 block-type-grid layout-3_column aspect-ratio-16-9" id="" >
		<header class="column-header">
				<h4 class="title"><a href="http://tampa.cbslocal.com/category/best-of">Latest Headlines</a></h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="https://tampa.cbslocal.com/2020/05/22/quarantine-cooking-nonstick-cookware-guide/" title="Quarantine Cooking: Your Essential Nonstick Cookware Guide" class="cbs-thumbnail-link item-1590161120 content-type-video" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://tampa.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://tampa.cbslocal.com/wp-content/uploads/sites/15909843/2020/05/nonstickpans.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Quarantine Cooking: Your Essential Nonstick Cookware Guide</strong><em class="description">Step up your quarantine cooking with this guide to nonstick cookware.</em></div></a><a href="https://tampa.cbslocal.com/2020/05/22/how-to-6-easy-steps-to-make-homemade-soft-pretzels/" title="How To: 6 Easy Steps To Make Homemade Soft Pretzels" class="cbs-thumbnail-link item-1590161082 content-type-video" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://tampa.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://tampa.cbslocal.com/wp-content/uploads/sites/15909843/2020/05/homemadepretzel.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">How To: 6 Easy Steps To Make Homemade Soft Pretzels</strong><em class="description">Learn how to make your own homemade soft pretzels with these six easy steps!</em></div></a><a href="https://tampa.cbslocal.com/2020/05/15/recipes-vodka-in-vodka-sauce-why/" title="5 Vodka Sauce Recipes To Try This Week" class="cbs-thumbnail-link item-1589569648 content-type-video" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://tampa.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://tampa.cbslocal.com/wp-content/uploads/sites/15909843/2020/05/chowhound111.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">5 Vodka Sauce Recipes To Try This Week</strong><em class="description">And would you miss it if it wasn&#039;t there?</em></div></a><a href="https://tampa.cbslocal.com/2020/05/15/best-make-ahead-freezer-meals/" title="Try These Make-Ahead Freezer Meals Perfect For Weeknights" class="cbs-thumbnail-link item-1589569416 content-type-video" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://tampa.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://tampa.cbslocal.com/wp-content/uploads/sites/15909843/2020/05/freezerfood.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Try These Make-Ahead Freezer Meals Perfect For Weeknights</strong><em class="description">Set yourself up for easy weeknight dinners no matter what!</em></div></a><a href="https://tampa.cbslocal.com/2020/05/13/the-most-searched-recipe-in-every-state-during-quarantine-coronavirus/" title="Coronavirus Cooking: The Most Searched Recipe In Every State During Quarantine" class="cbs-thumbnail-link item-1589398031 content-type-video" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://tampa.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://tampa.cbslocal.com/wp-content/uploads/sites/15909843/2020/05/QuarantineRecipesFeat.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Coronavirus Cooking: The Most Searched Recipe In Every State During Quarantine</strong><em class="description">Find the most popular eats for your home state and across the country during the coronavirus quarantine.</em></div></a><a href="https://tampa.cbslocal.com/2020/05/13/how-to-make-homemade-bagels-quarantine/" title="Quarantine Recipes: How To Make Homemade Bagels" class="cbs-thumbnail-link item-1589397541 content-type-video" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://tampa.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://tampa.cbslocal.com/wp-content/uploads/sites/15909843/2020/05/bagelfeat.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Quarantine Recipes: How To Make Homemade Bagels</strong><em class="description">See how to make your own homemade bagels while stuck inside during quarantine.</em></div></a>		</div>
	</section>
</div></div></li><li class="menu-top-item item-4 w-link w-submenu"><a href="http://tampa.cbslocal.com/category/sports/" title="Sports" class="cbs-thumbnail-link wo-hover" ><div class="title-wrapper"><strong class="title">Sports</strong></div></a><div class="submenu"><div class="wrapper">
<section class="items-grid column-count-2 block-type-wpmenu layout-compact aspect-ratio-16-9" id="" >
		<header class="column-header">
				<h4 class="title">View All Sports</h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="https://tampa.cbslocal.com/category/sports/" title="Latest" class="cbs-thumbnail-link item-0" ><div class="title-wrapper"><strong class="title">Latest</strong></div></a><a href="http://tampa.cbslocal.com/category/sports/rays/" title="Rays" class="cbs-thumbnail-link item-1" ><div class="title-wrapper"><strong class="title">Rays</strong></div></a><a href="http://www.cbssports.com/nfl/teams/page/TB/tampa-bay-buccaneers" title="Bucs" class="cbs-thumbnail-link item-2" ><div class="title-wrapper"><strong class="title">Bucs</strong></div></a><a href="http://tampa.cbslocal.com/category/sports/lightning/" title="Lightning" class="cbs-thumbnail-link item-3" ><div class="title-wrapper"><strong class="title">Lightning</strong></div></a><a href="http://www.cbssports.com/nfl/" title="NFL" class="cbs-thumbnail-link item-4" ><div class="title-wrapper"><strong class="title">NFL</strong></div></a><a href="http://www.cbssports.com/mlb/" title="MLB" class="cbs-thumbnail-link item-5" ><div class="title-wrapper"><strong class="title">MLB</strong></div></a><a href="http://www.cbssports.com/nba/" title="NBA" class="cbs-thumbnail-link item-6" ><div class="title-wrapper"><strong class="title">NBA</strong></div></a><a href="http://www.cbssports.com/nhl/" title="NHL" class="cbs-thumbnail-link item-7" ><div class="title-wrapper"><strong class="title">NHL</strong></div></a><a href="http://www.cbssports.com/college-football/" title="NCAAFB" class="cbs-thumbnail-link item-8" ><div class="title-wrapper"><strong class="title">NCAAFB</strong></div></a><a href="http://www.cbssports.com/college-basketball/" title="NCAAB" class="cbs-thumbnail-link item-9" ><div class="title-wrapper"><strong class="title">NCAAB</strong></div></a>		</div>
	</section>

<section class="items-grid enable-type-icons column-count-2 block-type-grid layout-3_column aspect-ratio-16-9" id="" >
		<header class="column-header">
				<h4 class="title">Featured Articles</h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="https://tampa.cbslocal.com/2020/07/24/nwsl-challenge-cup-final-houston-dash-james-clarkson-interview/" title="Houston Dash Head Coach James Clarkson On NWSL Challenge Cup Final: &#039;Our Feet Are Definitely On The Ground, There&#039;s A Real Focus In The Group&#039;" class="cbs-thumbnail-link item-1595598611 content-type-video" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://tampa.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://tampa.cbslocal.com/wp-content/uploads/sites/15909843/2020/07/GettyImages-1257629891.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Houston Dash Head Coach James Clarkson On NWSL Challenge Cup Final: &#039;Our Feet Are Definitely On The Ground, There&#039;s A Real Focus In The Group&#039;</strong><em class="description">The Dash head coach discusses the team&#039;s performance in the Challenge Cup and how they&#039;re feeling heading into the franchise&#039;s first ever final appearance.</em></div></a><a href="https://tampa.cbslocal.com/2020/07/22/andrew-catalon-3m-open-tpc-twin-cities-interview/" title="CBS Sports&#039; Andrew Catalon On TPC Twin Cities And 3M Open: &#039;This Golf Course Is Really Set Up For Fireworks At The Finish&#039;" class="cbs-thumbnail-link item-1595448467" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://tampa.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://tampa.cbslocal.com/wp-content/uploads/sites/15909843/2020/07/GettyImages-1160452319.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">CBS Sports&#039; Andrew Catalon On TPC Twin Cities And 3M Open: &#039;This Golf Course Is Really Set Up For Fireworks At The Finish&#039;</strong><em class="description">The 3M Open is set for this weekend and based on last year&#039;s tournament, CBS Sports announcer Andrew Catalon is expecting plenty of low numbers to be had.</em></div></a>		</div>
	</section>

<section class="items-grid enable-type-icons column-count-2 block-type-grid layout-3_column aspect-ratio-16-9" id="" >
		<header class="column-header">
				<h4 class="title">Latest Galleries</h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="https://tampa.cbslocal.com/photo-galleries/2014/12/30/final-nfl-power-rankings/" title="Final NFL Power Rankings" class="cbs-thumbnail-link item-1419918619 content-type-photo" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://tampa.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://tampa.cbslocal.com/wp-content/uploads/sites/15909843/2014/12/460879088.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">Final NFL Power Rankings</strong><em class="description">It&#039;s tough to keep up with all the action in NFL. Here&#039;s your final power rankings of the season.</em></div></a><a href="https://tampa.cbslocal.com/photo-galleries/2014/12/19/nfl-power-rankings-week-16/" title="NFL Power Rankings: Week 16" class="cbs-thumbnail-link item-1418966955 content-type-photo" ><div class="thumbnail-wrapper"><span class="balance"><img src="https://tampa.cbslocal.com/wp-content/themes/cbs-local/images/global/blank_1x1.gif" data-src="https://tampa.cbslocal.com/wp-content/uploads/sites/15909843/2014/12/460465244.jpg?w=310&#038;h=174&#038;crop=1"></span></div><div class="title-wrapper"><strong class="title">NFL Power Rankings: Week 16</strong><em class="description">It&#039;s tough to keep up with all the action in NFL. Here&#039;s your power rankings heading into Week 16.</em></div></a>		</div>
	</section>
</div></div></li><li class="menu-top-item item-5 w-link w-submenu"><a href="http://tampa.cbslocal.com/category/health/" title="Health" class="cbs-thumbnail-link wo-hover" ><div class="title-wrapper"><strong class="title">Health</strong></div></a><div class="submenu"><div class="wrapper"></div></div></li><li class="menu-top-item item-6 w-link w-submenu"><a href="http://tampa.cbslocal.com/category/contests/" title="Videos &amp; More" class="cbs-thumbnail-link wo-hover" ><div class="title-wrapper"><strong class="title">Videos &amp; More</strong></div></a><div class="submenu"><div class="wrapper">
<section class="items-grid column-count-1 block-type-wpmenu layout-compact aspect-ratio-16-9" id="" >
		<header class="column-header">
				<h4 class="title">Video</h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="https://tampa.cbslocal.com/live/cbsn-new-york/" title="CBSN NY" class="cbs-thumbnail-link item-0" ><div class="title-wrapper"><strong class="title">CBSN NY</strong></div></a><a href="https://tampa.cbslocal.com/live/cbsn/" title="CBSN" class="cbs-thumbnail-link item-1" ><div class="title-wrapper"><strong class="title">CBSN</strong></div></a><a href="https://tampa.cbslocal.com/live/cbs-sports-hq/" title="CBS Sports HQ" class="cbs-thumbnail-link item-2" ><div class="title-wrapper"><strong class="title">CBS Sports HQ</strong></div></a><a href="https://tampa.cbslocal.com/live/et-live/" title="ET Live" class="cbs-thumbnail-link item-3" ><div class="title-wrapper"><strong class="title">ET Live</strong></div></a>		</div>
	</section>
</div></div></li></ul></nav>
	
	
	<div id="info-search"><form action="https://tampa.cbslocal.com/search/" class="form"><input type="text" class="query" name="q" id="s" size="31" placeholder="Search..." /><input type="reset" class="reset" value="Reset" /><input type="submit" class="submit" value="&#xf002" /></form><span class="open-close" onclick="jQuery(document).ready(function(){jQuery('#info-search').toggleClass('open');});"></span></div>
</div></header>		<section class="page-ad-container page-pencil-ad-container-top">
			<div id="reptile_1_wrapper" class="ad-block-wrapper cbs-ad-unit-wrapper"><span id="ad_1"><div id="reptile_1" class="ad-block" data-ad_size="[[970,250],[970,66],[728,90]]" data-ad_location="top"><script>cbs_load_ad_by_tile("1");</script></div></span></div>		</section>
		
<div id="page-content" class="main-white page-block-container and-w-sidebar">
<header id="page-rubric" class="">

			<div class="banner-title-wrapper">
							<h1 class="title">&#8216;It Was A Dream Come True, I Can&#8217;t Believe It&#8217;: Joel McHale On CBS All Access&#8217;s &#8216;The Twilight Zone&#8217;</h1>
					</div>
	
	
	
	
	
</header>
<section class="page-columns"><section class="page-column three-column" id="article-entry-date-and-tags"><div class="column-header"><time class="post-date">July 27, 2020 at 1:03 pm</time><div class="column-header-metadata"><strong>Filed Under:</strong><span><a href="https://tampa.cbslocal.com/tag/cbs-all-access/">CBS All Access</a>, <a href="https://tampa.cbslocal.com/tag/dj-sixsmith/">DJ Sixsmith</a>, <a href="https://tampa.cbslocal.com/tag/joel-mchale/">Joel McHale</a>, <a href="https://tampa.cbslocal.com/tag/jordan-peele/">Jordan Peele</a>, <a href="https://tampa.cbslocal.com/tag/only-cbs/">Only CBS</a>, <a href="https://tampa.cbslocal.com/tag/the-twilight-zone/">the twilight zone</a></div></div></section><section id="column_block_1" class="page-column and-content-column two-column"><div class="column-item story" id="main-story"><section class="column-item media-type-anvato " id="featured-media"><div id="floating-player-container" class="video-wrapper anvato"><div id='p0'></div><script type="text/plain" class="optanon-category-4" async  data-anvp='{&quot;mcp&quot;:&quot;cbs&quot;,&quot;width&quot;:&quot;100%&quot;,&quot;height&quot;:&quot;100%&quot;,&quot;video&quot;:&quot;4643146&quot;,&quot;autoplay&quot;:true,&quot;titleVisible&quot;:false,&quot;accessKey&quot;:&quot;anvato_cbslocal_app_web_prod_547f3e49241ef0e5d30c79b2efbca5d92c698f67&quot;,&quot;accessControl&quot;:{&quot;preview&quot;:false},&quot;pInstance&quot;:&quot;p0&quot;,&quot;plugins&quot;:{&quot;dfp&quot;:{&quot;clientSide&quot;:{&quot;adTagUrl&quot;:&quot;http:\/\/pubads.g.doubleclick.net\/gampad\/ads?sz=2x2&amp;iu=\/4128\/CBS.TAMPA&amp;ciu_szs&amp;impl=s&amp;gdfp_req=1&amp;env=vp&amp;output=xml_vast2&amp;unviewed_position_start=1&amp;url=[referrer_url]&amp;description_url=[description_url]&amp;correlator=[timestamp]&quot;,&quot;keyValues&quot;:{&quot;categories&quot;:&quot;[[CATEGORIES]]&quot;,&quot;program&quot;:&quot;[[PROGRAM_NAME]]&quot;,&quot;siteSection&quot;:&quot;featured&quot;}}}},&quot;shareLink&quot;:&quot;https:\/\/cbsloc.al\/39xI6xW&quot;,&quot;video-type&quot;:&quot;featured&quot;,&quot;expectPreroll&quot;:true,&quot;expectPrerollTimeout&quot;:5}' src='https://w3.cdn.anvato.net/player/prod/v3/scripts/anvload.js'></script></div></section>
<div class="main-story-wrapper"><p><strong>(CBS Local)&#8211;&nbsp;</strong>Season two of &#8220;The Twilight Zone&#8221; is streaming now on CBS All Access and Joel McHale is in one of the season&#8217;s scariest episodes.</p>
<p><a href="https://newyork.cbslocal.com/2020/06/25/morena-baccarin-the-twilight-zone-jordan-peele/" target="_blank" rel="noopener noreferrer"><strong>RELATED: &#8216;As I Was Doing It, I Realized How Iconic That World Is&#8217;: Morena Baccarin On CBS All Access&#8217;s &#8216;The Twilight Zone&#8217;</strong></a></p>
<p>While the actor and comedian has made name for himself making people laugh, McHale jumped at the opportunity to work with Jordan Peele and enter a world he has long been a fan of.</p>
<div id="attachment_227673" style="width: 310px" class="wp-caption alignleft"><a href="https://tampa.cbslocal.com/wp-content/uploads/sites/15909843/2020/07/116826_0186b-1.jpg"><img aria-describedby="caption-attachment-227673" class="size-medium wp-image-227673" src="https://tampa.cbslocal.com/wp-content/uploads/sites/15909843/2020/07/116826_0186b-1.jpg?w=300" alt="" width="300" height="200" srcset="https://tampa.cbslocal.com/wp-content/uploads/sites/15909843/2020/07/116826_0186b-1.jpg 1200w, https://tampa.cbslocal.com/wp-content/uploads/sites/15909843/2020/07/116826_0186b-1.jpg?resize=300,200 300w, https://tampa.cbslocal.com/wp-content/uploads/sites/15909843/2020/07/116826_0186b-1.jpg?resize=768,512 768w, https://tampa.cbslocal.com/wp-content/uploads/sites/15909843/2020/07/116826_0186b-1.jpg?resize=1024,683 1024w, https://tampa.cbslocal.com/wp-content/uploads/sites/15909843/2020/07/116826_0186b-1.jpg?resize=640,427 640w, https://tampa.cbslocal.com/wp-content/uploads/sites/15909843/2020/07/116826_0186b-1.jpg?resize=310,207 310w, https://tampa.cbslocal.com/wp-content/uploads/sites/15909843/2020/07/116826_0186b-1.jpg?resize=960,640 960w, https://tampa.cbslocal.com/wp-content/uploads/sites/15909843/2020/07/116826_0186b-1.jpg?resize=222,148 222w" sizes="(max-width: 300px) 100vw, 300px" /></a><p id="caption-attachment-227673" class="wp-caption-text">Photo Credit: CBS</p></div>
<p>&#8220;It was a dream come true that I now get to say I was on The Twilight Zone,&#8221; said McHale in an interview with CBS Local&#8217;s DJ Sixsmith. &#8220;I can&#8217;t believe it. I grew up watching every episode and then I watched the movie The Twilight Zone. I was thrilled to be a part of it. We got to shoot for two weeks in Vancouver and I love it up there. It was right before COVID-19 and I look back on it in a very romantic and rosy way.&#8221;</p>
<p><strong>FULL INTERVIEW:</strong></p>
<div id='p1'></div><script type="text/plain" class="optanon-category-4" async  data-anvp='{&quot;mcp&quot;:&quot;cbs&quot;,&quot;width&quot;:&quot;100%&quot;,&quot;height&quot;:&quot;100%&quot;,&quot;video&quot;:&quot;4643141&quot;,&quot;autoplay&quot;:false,&quot;titleVisible&quot;:false,&quot;accessKey&quot;:&quot;anvato_cbslocal_app_web_prod_547f3e49241ef0e5d30c79b2efbca5d92c698f67&quot;,&quot;accessControl&quot;:{&quot;preview&quot;:false},&quot;pInstance&quot;:&quot;p1&quot;,&quot;plugins&quot;:{&quot;dfp&quot;:{&quot;clientSide&quot;:{&quot;adTagUrl&quot;:&quot;http:\/\/pubads.g.doubleclick.net\/gampad\/ads?sz=2x2&amp;iu=\/4128\/CBS.TAMPA&amp;ciu_szs&amp;impl=s&amp;gdfp_req=1&amp;env=vp&amp;output=xml_vast2&amp;unviewed_position_start=1&amp;url=[referrer_url]&amp;description_url=[description_url]&amp;correlator=[timestamp]&quot;,&quot;keyValues&quot;:{&quot;categories&quot;:&quot;[[CATEGORIES]]&quot;,&quot;program&quot;:&quot;[[PROGRAM_NAME]]&quot;,&quot;siteSection&quot;:&quot;video-default&quot;}}}},&quot;expectPreroll&quot;:true,&quot;expectPrerollTimeout&quot;:5}' src='https://w3.cdn.anvato.net/player/prod/v3/scripts/anvload.js'></script>
<p><a href="https://losangeles.cbslocal.com/2020/07/20/kylie-bunbury-the-twilight-zone-interview/" target="_blank" rel="noopener noreferrer"><strong>RELATED: &#8216;Jordan Peele Is A Very Unique Genius&#8217;: Kylie Bunbury On CBS All Access&#8217;s &#8216;The Twilight Zone&#8217;</strong></a></p>
<p>McHale&#8217;s episode is called &#8220;8&#8221; and it tells the story of a team of scientists who discover a new highly intelligent species that threatens to take over the world. The actor was blown away by the opportunity to work with Peele and explore some of the topics of the show.</p>
<p>&#8220;Rod Serling pulled off something that was like going to the moon,&#8221; said McHale. &#8220;The amount of work he did and so many that he wrote, I don&#8217;t know how he got it through. Some of those episodes are damn terrifying. To think that these were on in people&#8217;s homes in the 60s is crazy. They hold up because his vision and he did not compromise. The direction it&#8217;s going with Jordan [Peele] and he was there and he was great and really cool. I would do it again in a New York minute, it was so much fun. Jordan is very easy going and this sonic boom of a genius in there. His touch is clearly on it.&#8221;</p>
<p>Watch &#8220;The Twilight Zone&#8221; on CBS All Access now.</p>
<div class="social-buttons">
	<div class="social-media-container vertical">
					<div class="social-share-items addthis_toolbox addthis_default_style addthis_32x32_style">
				<span><a class="addthis_button_facebook"  addthis:url="https://cbsloc.al/39xI6xW"></a><a class="addthis_button_twitter"  addthis:url="https://cbsloc.al/39xI6xW"></a><a href="#" class="addthis_button_linkedin"></a><a href="#" class="addthis_button_reddit"></a><a class="addthis_button_compact"  addthis:url="https://cbsloc.al/39xI6xW"></a></span>
			</div>
		
			</div>
</div></div></div><a href="#" id="enable-comments-button" class="generic-button-v1" onclick="document.getElementById('story-comments').style.display=(document.getElementById('story-comments').style.display==='block')?'none':'block';return false;">Comments</a>
	<style>
	#comments .comments-title,
	#comments #respond #reply-title {
		color: black;
		font-size: 16px;
		font-weight: normal;
		margin-bottom: 20px;
	}
	#comments a:hover {
		text-decoration: underline;
	}
	#comments .comment-list,
	#comments .comment-list .children {
		list-style: none;
		margin: 0;
	}
		#comments .comment-list .comment {
			border-top: 1px solid #eaeaea;
			padding: 20px 10px;
		}
			#comments .comment-list .comment .comment-body {
				color: black;
				font-size: 13px;
				position: relative;
			}
				#comments .comment-list .comment .comment-body p {
					margin: 5px 0 7px 0;
					overflow: hidden;
					padding: 0;
				}
			#comments .comment-list .comment .comment-author .avatar {
				float: left;
				height: 42px;
				margin-bottom: 10px;
				margin-right: 15px;
				width: 42px;
			}
			#comments .comment-list .comment .comment-author .fn {
				color: black;
				font-size: 13px;
				font-style: normal;
				font-weight: bold;
			}
			#comments .comment-list .comment .comment-author .says {
				display: none;
			}

			#comments .comment-list .comment .comment-meta {
				position: absolute;
				right: 0;
				top: 0;
			}
			#comments .comment-list .comment .reply {
				margin-left: 57px;
			}
			#comments .comment-list .comment .comment-meta a,
			#comments .comment-list .comment .reply a {
				color: #808080;
				font-size: 11px;
			}
				#comments .comment-list:hover .comment .comment-meta a,
				#comments .comment-list:hover .comment .reply a {
					color: #333;
				}
			#comments .comment-list .comment .reply .safe-comments-report-link:last-of-type {
				display: none;
			}
	#comments .comment-list .children {
		margin-left: 20px;
		margin-top: 20px;
	}
		#comments .comment-list .children .comment {
			border-top: none;
			padding-right: 0;
			padding-top: 0;
		}

	#comments #reply-title a {
		color: black;
		font-size: 13px;
		padding: 0 5px;
	}
		#comments #reply-title small a {
			font-weight: normal;
		}
	



</style>

<div class="commenting-container">
	<a name="comments" class="comments-location-beacon"></a>
	<section id="story-comments" class="column-item">

		<div id="comments" class="comments-area">

			
							<p class="must-log-in">You must <a href="https://tampa.cbslocal.com/wp-login.php?redirect_to=https%3A%2F%2Ftampa.cbslocal.com%2F2020%2F07%2F27%2Fjoel-mchale-the-twilight-zone-interview%2F%23respond">log in</a> to post a comment.</p>			
		</div>

	</section>
</div>
<div id="reptile_30_wrapper" class="ad-block-wrapper cbs-ad-unit-wrapper partner-container partner-sharethrough"><span id="ad_30"><div id="reptile_30" class="ad-block" data-ad_size="[[1,5]]" data-ad_location="partner-injected"><script>cbs_load_ad_by_tile("30");</script></div></span></div><div class="partner-container partner-taboola"><div id="taboola-block-2"></div></div></section><aside class="sidebar right-bar" rel="modular+"><div id="reptile_2_wrapper" class="ad-block-wrapper cbs-ad-unit-wrapper"><span id="ad_2"><div id="reptile_2" class="ad-block" data-ad_size="[[300,250],[300,600],[300,1050]]" data-ad_location="top"><script>cbs_load_ad_by_tile("2");</script></div></span></div><div id="" class="block sidebar-widget widget_cbs_follow_us_widget"><h3 class="title">Follow Us</h3>
		<div class="widget-content-wrapper">
			<a href="https://www.facebook.com/CBSTampaBay" target="_blank" title="facebook_url" class="cbs-thumbnail-link facebook_url" ><div class="title-wrapper"><strong class="title">facebook_url</strong></div></a><a href="https://twitter.com/CBSTampaBay" target="_blank" title="twitter_url" class="cbs-thumbnail-link twitter_url" ><div class="title-wrapper"><strong class="title">twitter_url</strong></div></a>		</div>

		</div><div id="" class="block sidebar-widget widget_top-posts"><h3 class="title"><span>Most </span> Viewed</h3><ul class='widgets-list-layout no-grav'>
					<li>
						<a href="https://tampa.cbslocal.com/2020/07/22/update-arrests-made-in-frostproof-triple-murder-massacre-of-3-friends-fishing-18/" title="UPDATE: Arrests Made In Frostproof Triple Murder Massacre Of 3 Friends Fishing" class="bump-view" data-bump-view="tp">
								<img width="55" height="55" src="https://i0.wp.com/tampa.cbslocal.com/wp-content/uploads/sites/15909843/2020/07/Frostproof-Massacre-Arrests.jpg?resize=55%2C55&#038;ssl=1" alt="UPDATE: Arrests Made In Frostproof Triple Murder Massacre Of 3 Friends Fishing" data-pin-nopin="true" class="widgets-list-layout-blavatar"/>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://tampa.cbslocal.com/2020/07/22/update-arrests-made-in-frostproof-triple-murder-massacre-of-3-friends-fishing-18/" title="UPDATE: Arrests Made In Frostproof Triple Murder Massacre Of 3 Friends Fishing" class="bump-view" data-bump-view="tp">UPDATE: Arrests Made In Frostproof Triple Murder Massacre Of 3 Friends Fishing</a>
							</div>
													</li>
										<li>
						<a href="https://tampa.cbslocal.com/2020/07/27/gwinnett-police-release-last-living-photos-burned-body/" title="Gwinnett Police Release Last Living Photos Of Man Found Burned" class="bump-view" data-bump-view="tp">
								<img width="55" height="55" src="https://i0.wp.com/tampa.cbslocal.com/wp-content/uploads/sites/15909843/2020/07/Raul-Zapata-Garcia.jpg?resize=55%2C55&#038;ssl=1" alt="Gwinnett Police Release Last Living Photos Of Man Found Burned" data-pin-nopin="true" class="widgets-list-layout-blavatar"/>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://tampa.cbslocal.com/2020/07/27/gwinnett-police-release-last-living-photos-burned-body/" title="Gwinnett Police Release Last Living Photos Of Man Found Burned" class="bump-view" data-bump-view="tp">Gwinnett Police Release Last Living Photos Of Man Found Burned</a>
							</div>
													</li>
										<li>
						<a href="https://tampa.cbslocal.com/2020/07/25/ft-meade-man-arrested-for-70-counts-of-possession-of-child-porn/" title="Ft. Meade Man Arrested For 70 Counts Of Possession Of Child Porn" class="bump-view" data-bump-view="tp">
								<img width="55" height="55" src="https://i2.wp.com/tampa.cbslocal.com/wp-content/uploads/sites/15909843/2020/07/Steven-Lacy-DeVane_Arrest_PCSO.jpg?resize=55%2C55&#038;ssl=1" alt="Ft. Meade Man Arrested For 70 Counts Of Possession Of Child Porn" data-pin-nopin="true" class="widgets-list-layout-blavatar"/>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://tampa.cbslocal.com/2020/07/25/ft-meade-man-arrested-for-70-counts-of-possession-of-child-porn/" title="Ft. Meade Man Arrested For 70 Counts Of Possession Of Child Porn" class="bump-view" data-bump-view="tp">Ft. Meade Man Arrested For 70 Counts Of Possession Of Child Porn</a>
							</div>
													</li>
										<li>
						<a href="https://tampa.cbslocal.com/2020/07/22/update-frostproof-triple-murder-massacre-of-3-friends-fishing-1/" title="UPDATE: Frostproof Triple Murder Massacre Of 3 Friends Fishing" class="bump-view" data-bump-view="tp">
								<img width="55" height="55" src="https://i0.wp.com/tampa.cbslocal.com/wp-content/uploads/sites/15909843/2020/07/Frostproof-Triple-Homicide.jpg?resize=55%2C55&#038;ssl=1" alt="UPDATE: Frostproof Triple Murder Massacre Of 3 Friends Fishing" data-pin-nopin="true" class="widgets-list-layout-blavatar"/>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://tampa.cbslocal.com/2020/07/22/update-frostproof-triple-murder-massacre-of-3-friends-fishing-1/" title="UPDATE: Frostproof Triple Murder Massacre Of 3 Friends Fishing" class="bump-view" data-bump-view="tp">UPDATE: Frostproof Triple Murder Massacre Of 3 Friends Fishing</a>
							</div>
													</li>
										<li>
						<a href="https://tampa.cbslocal.com/2020/07/20/3-friends-massacred-while-fishing-sheriff-grady-judd-requesting-information-56/" title="UPDATE: 3 Friends Massacred While Fishing, Sheriff Grady Judd Requesting Information" class="bump-view" data-bump-view="tp">
								<img width="55" height="55" src="https://i2.wp.com/tampa.cbslocal.com/wp-content/uploads/sites/15909843/2020/07/10abdc8b-beeb-450e-a857-3108af5055c5.jpg?resize=55%2C55&#038;ssl=1" alt="UPDATE: 3 Friends Massacred While Fishing, Sheriff Grady Judd Requesting Information" data-pin-nopin="true" class="widgets-list-layout-blavatar"/>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://tampa.cbslocal.com/2020/07/20/3-friends-massacred-while-fishing-sheriff-grady-judd-requesting-information-56/" title="UPDATE: 3 Friends Massacred While Fishing, Sheriff Grady Judd Requesting Information" class="bump-view" data-bump-view="tp">UPDATE: 3 Friends Massacred While Fishing, Sheriff Grady Judd Requesting Information</a>
							</div>
													</li>
										<li>
						<a href="https://tampa.cbslocal.com/2020/07/22/georgia-colleges-release-plans-to-reopen-campuses-for-2020-21-school-year/" title="Georgia Colleges Release Plans To Reopen Campuses For 2020-21 School Year" class="bump-view" data-bump-view="tp">
								<img width="55" height="55" src="https://i2.wp.com/tampa.cbslocal.com/wp-content/uploads/sites/15909843/2020/07/451875060.jpg?resize=55%2C55&#038;ssl=1" alt="Georgia Colleges Release Plans To Reopen Campuses For 2020-21 School Year" data-pin-nopin="true" class="widgets-list-layout-blavatar"/>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://tampa.cbslocal.com/2020/07/22/georgia-colleges-release-plans-to-reopen-campuses-for-2020-21-school-year/" title="Georgia Colleges Release Plans To Reopen Campuses For 2020-21 School Year" class="bump-view" data-bump-view="tp">Georgia Colleges Release Plans To Reopen Campuses For 2020-21 School Year</a>
							</div>
													</li>
										<li>
						<a href="https://tampa.cbslocal.com/2020/07/22/man-found-dead-in-tampa-bay-area-body-shop-1/" title="UPDATE: Man Found Dead In Tampa Bay Area Body Shop" class="bump-view" data-bump-view="tp">
								<img width="55" height="55" src="https://i0.wp.com/tampa.cbslocal.com/wp-content/uploads/sites/15909843/2014/12/crime-scene-black-car-reflection-e1533136484810.jpg?resize=55%2C55&#038;ssl=1" alt="UPDATE: Man Found Dead In Tampa Bay Area Body Shop" data-pin-nopin="true" class="widgets-list-layout-blavatar"/>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://tampa.cbslocal.com/2020/07/22/man-found-dead-in-tampa-bay-area-body-shop-1/" title="UPDATE: Man Found Dead In Tampa Bay Area Body Shop" class="bump-view" data-bump-view="tp">UPDATE: Man Found Dead In Tampa Bay Area Body Shop</a>
							</div>
													</li>
										<li>
						<a href="https://tampa.cbslocal.com/2020/07/22/citrus-county-school-board-approves-new-school-start-date-mask-policy/" title="Citrus County School Board Approves New School Start Date &amp; Mask Policy" class="bump-view" data-bump-view="tp">
								<img width="55" height="55" src="https://i0.wp.com/tampa.cbslocal.com/wp-content/uploads/sites/15909843/2020/07/Social-Distancing-At-Florida-Schools.jpg?resize=55%2C55&#038;ssl=1" alt="Citrus County School Board Approves New School Start Date &amp; Mask Policy" data-pin-nopin="true" class="widgets-list-layout-blavatar"/>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://tampa.cbslocal.com/2020/07/22/citrus-county-school-board-approves-new-school-start-date-mask-policy/" title="Citrus County School Board Approves New School Start Date &amp; Mask Policy" class="bump-view" data-bump-view="tp">Citrus County School Board Approves New School Start Date &amp; Mask Policy</a>
							</div>
													</li>
										<li>
						<a href="https://tampa.cbslocal.com/2020/07/10/atlanta-comedian-entertainer-dc-young-fly-says-cousin-killed-in-july-4th-weekend-shooting/" title="Atlanta Comedian, Entertainer DC Young Fly Says Cousin Killed In July 4th Weekend Shooting" class="bump-view" data-bump-view="tp">
								<img width="55" height="55" src="https://i2.wp.com/tampa.cbslocal.com/wp-content/uploads/sites/15909843/2020/07/GettyImages-1164052961.jpg?resize=55%2C55&#038;ssl=1" alt="Atlanta Comedian, Entertainer DC Young Fly Says Cousin Killed In July 4th Weekend Shooting" data-pin-nopin="true" class="widgets-list-layout-blavatar"/>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://tampa.cbslocal.com/2020/07/10/atlanta-comedian-entertainer-dc-young-fly-says-cousin-killed-in-july-4th-weekend-shooting/" title="Atlanta Comedian, Entertainer DC Young Fly Says Cousin Killed In July 4th Weekend Shooting" class="bump-view" data-bump-view="tp">Atlanta Comedian, Entertainer DC Young Fly Says Cousin Killed In July 4th Weekend Shooting</a>
							</div>
													</li>
										<li>
						<a href="https://tampa.cbslocal.com/2020/07/22/pedestrian-struck-and-killed-crossing-4th-street-in-st-pete-1/" title="Pedestrian Struck And Killed Crossing 4th Street In St. Pete" class="bump-view" data-bump-view="tp">
								<img width="55" height="55" src="https://i1.wp.com/tampa.cbslocal.com/wp-content/uploads/sites/15909843/2020/06/iStock-1053183826.jpg?resize=55%2C55&#038;ssl=1" alt="Pedestrian Struck And Killed Crossing 4th Street In St. Pete" data-pin-nopin="true" class="widgets-list-layout-blavatar"/>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://tampa.cbslocal.com/2020/07/22/pedestrian-struck-and-killed-crossing-4th-street-in-st-pete-1/" title="Pedestrian Struck And Killed Crossing 4th Street In St. Pete" class="bump-view" data-bump-view="tp">Pedestrian Struck And Killed Crossing 4th Street In St. Pete</a>
							</div>
													</li>
					</ul>
</div><div id="reptile_31_wrapper" class="ad-block-wrapper cbs-ad-unit-wrapper big-right-ad sidebar-adhesive-ad"><span id="ad_31"><div id="reptile_31" class="ad-block" data-ad_size="[[300,250]]" data-ad_location="adhesion"><script>cbs_load_ad_by_tile("31");</script></div></span></div></aside></section>		<section class="page-ad-container page-pencil-ad-container-bottom">
			<div id="reptile_4_wrapper" class="ad-block-wrapper cbs-ad-unit-wrapper"><span id="ad_4"><div id="reptile_4" class="ad-block" data-ad_size="[[728,90]]" data-ad_location="bottom"><script>cbs_load_ad_by_tile("4");</script></div></span></div>		</section>
		

</div>


<footer id="page-footer" class="page-footer-type-menus-vertical">
			<section class="top"><div class="wrapper">
										<div id="component-social" class="footer-component social-follow-items type-blue size-24x24">
					<div class="social-align-wrapper">
						<span class="disclosure">Follow Us</span>
						<a href="https://www.facebook.com/CBSTampaBay" class="facebook" target="_blank">Facebook</a><a href="https://twitter.com/CBSTampaBay" class="twitter" target="_blank">Twitter</a>					</div>
				</div>
					</div></section>
	
			<section class="middle"><div class="wrapper">
			
<section class="items-grid block-menu layout-compact aspect-ratio-16-9" id="block-0" >
		<header class="column-header">
				<h4 class="title">Entertainment</h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="https://tampa.cbslocal.com/category/only-cbs/" title="Only CBS" class="cbs-thumbnail-link item-0" ><div class="title-wrapper"><strong class="title">Only CBS</strong></div></a><a href="/category/best-of/" title="Best Of" class="cbs-thumbnail-link item-1" ><div class="title-wrapper"><strong class="title">Best Of</strong></div></a><a href="https://tampa.cbslocal.com/category/travel/" title="Travel" class="cbs-thumbnail-link item-2" ><div class="title-wrapper"><strong class="title">Travel</strong></div></a><a href="http://cwtampa.cbslocal.com/" title="CW44" class="cbs-thumbnail-link item-3" ><div class="title-wrapper"><strong class="title">CW44</strong></div></a>		</div>
	</section>

<section class="items-grid block-menu layout-compact aspect-ratio-16-9" id="block-1" >
		<header class="column-header">
				<h4 class="title">Corporate</h4>
	</header>
	
		
			<div class="article-buckets-list">
			<a href="http://tampa.cbslocal.com/about-us/" title="About Us" class="cbs-thumbnail-link item-0" ><div class="title-wrapper"><strong class="title">About Us</strong></div></a><a href="http://tampa.cbslocal.com/about-us/advertising-basics/" title="Advertise" class="cbs-thumbnail-link item-1" ><div class="title-wrapper"><strong class="title">Advertise</strong></div></a><a href="https://cwtampa.cbslocal.com/contactus/" title="Contact Us" class="cbs-thumbnail-link item-2" ><div class="title-wrapper"><strong class="title">Contact Us</strong></div></a>		</div>
	</section>
		</div></section>
	
			<section class="bottom"><div class="wrapper">
			<a href="https://tampa.cbslocal.com" class="logo"><img src="https://tampa.cbslocal.com/wp-content/themes/cbs-local/plugins/modules/theme-manager/images/cbs-local-logo-white.png" alt="CBS Tampa" /></a>
			<div class="copyright-wrapper">
				<span class="copyright">&copy;2020 CBS Broadcasting Inc. All Rights Reserved.</span>
									<span class="powered-by-wordpress">Powered by <a href="https://wpvip.com/?utm_source=vip_powered_wpcom&#038;utm_medium=web&#038;utm_campaign=VIP%20Footer%20Credit&#038;utm_term=tampa.cbslocal.com" rel="generator nofollow" class="powered-by-wpcom">WordPress.com VIP</a></span>
							</div>

			<div class="right-wrapper">
									<div class="terms-of-use">By viewing our video content, you are accepting the terms of our <a href="https://privacy.cbs/videoservices" target="_blank" title="Video Services Policy">Video Services Policy</a></div>
								<ul id="menu-final-footer-menu" class="nav-final-footer"><li id="menu-item-44045" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-44045"><a href="http://policies.cbslocal.com/privacy/current.html">Privacy Policy</a></li>
<li id="menu-item-44046" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-44046"><a href="http://policies.cbslocal.com/terms-of-use">Terms of Use</a></li>
<li id="menu-item-172019" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-172019"><a href="https://publicfiles.fcc.gov/tv-profile/wtog">Public File for WTOG-TV / CW 44</a></li>
<li id="menu-item-208371" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-208371"><a href="https://cwtampa.cbslocal.com/wp-content/uploads/sites/31326193/2019/09/EEO-10-1-2018-to-9-30-2019.pdf">Public File Contact Us for WTOG-TV / CW 44</a></li>
<li id="menu-item-218783" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-218783"><a href="https://ca.privacy.cbs">California Privacy/Info We Collect</a></li>
<li id="menu-item-218784" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-218784"><a href="https://ca.privacy.cbs/donotsell">California Do Not Sell My Info</a></li>
<li id="menu-item-161080" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-161080"><a href="http://policies.cbslocal.com/mobile-app-agreement/">Mobile User Agreement</a></li>
<li id="menu-item-77985" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-77985"><a href="http://policies.cbslocal.com/privacy/current.html#onlinead">Ad Choices</a></li>
</ul>			</div>

						</div></section>
</footer>

<!--PARTNER SCRIPTS START-->
<div id="reptile_32_wrapper" class="ad-block-wrapper cbs-ad-unit-wrapper pixel-ad"><span id="ad_32"><div id="reptile_32" class="ad-block" data-ad_size="[[1,8]]" data-ad_location=""><script>cbs_load_ad_by_tile("32");</script></div></span></div><div id="reptile_33_wrapper" class="ad-block-wrapper cbs-ad-unit-wrapper pixel-ad"><span id="ad_33"><div id="reptile_33" class="ad-block" data-ad_size="[[1,6]]" data-ad_location=""><script>cbs_load_ad_by_tile("33");</script></div></span></div><div id="reptile_34_wrapper" class="ad-block-wrapper cbs-ad-unit-wrapper pixel-ad"><span id="ad_34"><div id="reptile_34" class="ad-block" data-ad_size="[[1,7]]" data-ad_location=""><script>cbs_load_ad_by_tile("34");</script></div></span></div>
<!--PARTNER SCRIPTS END-->


</div>

<link rel='stylesheet' id='all-css-0' href='https://tampa.cbslocal.com/wp-content/themes/cbs-local/plugins/modules/partners/css/partners.css?m=1563273633g' type='text/css' media='all' />
<script type='text/javascript' src='https://tampa.cbslocal.com/wp-includes/js/wp-embed.min.js?m=1591831597g'></script>

		<!--[if IE]>
		<script type="text/javascript">
			if ( 0 === window.location.hash.indexOf( '#comment-' ) ) {
				// window.location.reload() doesn't respect the Hash in IE
				window.location.hash = window.location.hash;
			}
		</script>
		<![endif]-->
		<script type="text/javascript">
			(function () {
				var comm_par_el = document.getElementById( 'comment_parent' ),
					comm_par = ( comm_par_el && comm_par_el.value ) ? comm_par_el.value : '',
					frame = document.getElementById( 'jetpack_remote_comment' ),
					tellFrameNewParent;

				tellFrameNewParent = function () {
					if ( comm_par ) {
						frame.src = "" + '&replytocom=' + parseInt( comm_par, 10 ).toString();
					} else {
						frame.src = "";
					}
				};

				
				if ( 'undefined' !== typeof addComment ) {
					addComment._Jetpack_moveForm = addComment.moveForm;

					addComment.moveForm = function ( commId, parentId, respondId, postId ) {
						var returnValue = addComment._Jetpack_moveForm( commId, parentId, respondId, postId ),
							cancelClick, cancel;

						if ( false === returnValue ) {
							cancel = document.getElementById( 'cancel-comment-reply-link' );
							cancelClick = cancel.onclick;
							cancel.onclick = function () {
								var cancelReturn = cancelClick.call( this );
								if ( false !== cancelReturn ) {
									return cancelReturn;
								}

								if ( ! comm_par ) {
									return cancelReturn;
								}

								comm_par = 0;

								tellFrameNewParent();

								return cancelReturn;
							};
						}

						if ( comm_par == parentId ) {
							return returnValue;
						}

						comm_par = parentId;

						tellFrameNewParent();

						return returnValue;
					};
				}

				
				// Do the post message bit after the dom has loaded.
				document.addEventListener( 'DOMContentLoaded', function () {
					var iframe_url = "https:\/\/jetpack.wordpress.com";
					if ( window.postMessage ) {
						if ( document.addEventListener ) {
							window.addEventListener( 'message', function ( event ) {
								var origin = event.origin.replace( /^http:\/\//i, 'https://' );
								if ( iframe_url.replace( /^http:\/\//i, 'https://' ) !== origin ) {
									return;
								}
								jQuery( frame ).height( event.data );
							});
						} else if ( document.attachEvent ) {
							window.attachEvent( 'message', function ( event ) {
								var origin = event.origin.replace( /^http:\/\//i, 'https://' );
								if ( iframe_url.replace( /^http:\/\//i, 'https://' ) !== origin ) {
									return;
								}
								jQuery( frame ).height( event.data );
							});
						}
					}
				})

			})();
		</script>

		<script type='text/javascript' src='https://stats.wp.com/e-202031.js' async='async' defer='defer'></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:8.7.1',blog:'162238304',post:'227671',tz:'-4',srv:'tampa.cbslocal.com'} ]);
	_stq.push([ 'clickTrackerInit', '162238304', '227671' ]);
</script>



<script type="text/javascript">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</script>

	
	
	
	
</body>
</html>